summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch56
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_1.0.5.bb37
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_2.0.3.bb26
3 files changed, 26 insertions, 93 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch b/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch
deleted file mode 100644
index c82f3bf017..0000000000
--- a/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1From 73d2aea33e32272bac693550e8a3b0e3ad89707f Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Jan=20Pokorn=C3=BD?= <jpokorny@redhat.com>
3Date: Tue, 26 Dec 2017 00:02:26 +0100
4Subject: [PATCH] build: fix configure script neglecting, re-enable out-of-tree
5 builds
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10For the former, a prototype and the final code got (hm, mysteriously)
11intertwisted. For the latter, I am clearly guilty of (rare, anyway)
12testing of the out-of-tree builds only with libqb-already-system-wide
13scenario, which is rather shortsighted.
14
15Thanks Fabio and his ci.kronosnet.org project for spotting that.
16
17X-mas-present-for: Fabio M. Di Nitto <fdinitto@redhat.com>
18Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
19---
20Upstream-Status: Backport
21
22 configure.ac | 2 +-
23 lib/Makefile.am | 4 +++-
24 2 files changed, 4 insertions(+), 2 deletions(-)
25
26diff --git a/configure.ac b/configure.ac
27index 9900310..f9761cc 100644
28--- a/configure.ac
29+++ b/configure.ac
30@@ -710,7 +710,7 @@ if test "x${GCC}" = xyes; then
31 | grep __stop___verbose | cut -d" " -f 3)
32 test "${verbose_start_addr}" = "${verbose_stop_addr}" \
33 && gcc_has_attribute_section_visible=no \
34- || { verbose_start_type=$(${READELF} -s backup \
35+ || { verbose_start_type=$(${READELF} -s "conftest${shrext_cmds}" \
36 | sed -n '/__start___verbose/{s/^\s*//p;q}' \
37 | tr -s ' ' \
38 | cut -d" " -f6)
39diff --git a/lib/Makefile.am b/lib/Makefile.am
40index 6ca6b15..b035f0b 100644
41--- a/lib/Makefile.am
42+++ b/lib/Makefile.am
43@@ -101,7 +101,9 @@ endif
44 endif
45
46 qblog_script.ld: %.ld: %.ld.in
47- $(AM_V_GEN)$(CPP) -xc -I$(top_srcdir)/include -D_GNU_SOURCE -C -P $< \
48+ $(AM_V_GEN)$(CPP) -C -D_GNU_SOURCE -P \
49+ -I$(top_srcdir)/include -I$(top_builddir)/include \
50+ -xc $< \
51 | sed -n "/$$(sed -n '/^[^#]/{s/[*\/]/\\&/g;p;q;}' $<)/,$$ p" \
52 > $@
53
54--
552.16.2
56
diff --git a/meta-oe/recipes-extended/libqb/libqb_1.0.5.bb b/meta-oe/recipes-extended/libqb/libqb_1.0.5.bb
deleted file mode 100644
index d14fbaed3e..0000000000
--- a/meta-oe/recipes-extended/libqb/libqb_1.0.5.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1SUMMARY = "An IPC library for high performance servers"
2DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
3It provides high performance logging, tracing, ipc, and poll."
4
5HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
6SECTION = "libs"
7LICENSE = "LGPL-2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
9
10inherit autotools pkgconfig
11
12# v1.0.5
13SRCREV = "d08dbcf08b0da418bce9b5427dfd89522916322a"
14SRC_URI = "git://github.com/ClusterLabs/${BPN}.git;branch=version_1 \
15 file://0001-build-fix-configure-script-neglecting-re-enable-out-.patch \
16 "
17S = "${WORKDIR}/git"
18
19# otherwise do_configure fails
20# configure:21609: checking whether linker workaround for orphan sections usable
21# configure:21639: i586-oe-linux-gcc -m32 -march=i586 --sysroot=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot -o conftest -O -fno-omit-frame-pointer -g -feliminate-unused-debug-types -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0=/usr/src/debug/libqb/1.0.3+gitAUTOINC+c235284b5f-r0 -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot= -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native= -pipe -pthread -D_REENTRANT -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,conftest.ld conftest.c >&5
22# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: error: conftest.ld: SECTIONS seen after other input files; try -T/--script
23# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: internal error in write_sections, at ../../gold/reloc.cc:791
24# collect2: error: ld returned 1 exit status
25NOSECTION_FALLBACK = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '--enable-nosection-fallback', '', d)}"
26NOSECTION_FALLBACK:toolchain-clang:mips64 = "--enable-nosection-fallback"
27
28EXTRA_OECONF += "${NOSECTION_FALLBACK}"
29
30CFLAGS += "-pthread -D_REENTRANT"
31
32do_configure:prepend() {
33 ( cd ${S}
34 ${S}/autogen.sh )
35}
36
37BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-extended/libqb/libqb_2.0.3.bb b/meta-oe/recipes-extended/libqb/libqb_2.0.3.bb
new file mode 100644
index 0000000000..18d6a4f27c
--- /dev/null
+++ b/meta-oe/recipes-extended/libqb/libqb_2.0.3.bb
@@ -0,0 +1,26 @@
1SUMMARY = "An IPC library for high performance servers"
2DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
3It provides high performance logging, tracing, ipc, and poll."
4
5HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
6SECTION = "libs"
7LICENSE = "LGPL-2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
9
10inherit autotools pkgconfig
11
12SRCREV = "404adbcd998ec83643e47d92b3ea8d9c3970e68b"
13SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \
14 "
15S = "${WORKDIR}/git"
16
17DEPENDS += "libxml2"
18
19CFLAGS += "-pthread -D_REENTRANT"
20
21do_configure:prepend() {
22 ( cd ${S}
23 ${S}/autogen.sh )
24}
25
26BBCLASSEXTEND = "native"