diff options
3 files changed, 46 insertions, 41 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/0001-add-support-for-big-endian-32bit-ARM.patch b/meta-oe/recipes-extended/mozjs/mozjs/0001-add-support-for-big-endian-32bit-ARM.patch deleted file mode 100644 index 7b7038f6fb..0000000000 --- a/meta-oe/recipes-extended/mozjs/mozjs/0001-add-support-for-big-endian-32bit-ARM.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 07830cbc409f8e998fa839275470031fc83d6eb6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen.kooi@linaro.org> | ||
3 | Date: Thu, 21 Apr 2016 14:10:54 +0200 | ||
4 | Subject: [PATCH] add support for big endian 32bit ARM | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen.kooi@linaro.org> | ||
7 | --- | ||
8 | mfbt/double-conversion/utils.h | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/mfbt/double-conversion/utils.h b/mfbt/double-conversion/utils.h | ||
12 | index fe26dab..78a19cb 100644 | ||
13 | --- a/mfbt/double-conversion/utils.h | ||
14 | +++ b/mfbt/double-conversion/utils.h | ||
15 | @@ -58,7 +58,7 @@ | ||
16 | defined(__mips__) || defined(__powerpc__) || \ | ||
17 | defined(__sparc__) || defined(__sparc) || defined(__s390__) || \ | ||
18 | defined(__SH4__) || defined(__alpha__) || \ | ||
19 | - defined(__aarch64__) || \ | ||
20 | + defined(__aarch64__) || defined(__ARMEB__) || \ | ||
21 | defined(_MIPS_ARCH_MIPS32R2) | ||
22 | #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1 | ||
23 | #elif defined(_M_IX86) || defined(__i386__) || defined(__i386) | ||
24 | -- | ||
25 | 2.4.3 | ||
26 | |||
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/0001-compare-the-first-character-of-string-to-be-null-or-.patch b/meta-oe/recipes-extended/mozjs/mozjs/0001-compare-the-first-character-of-string-to-be-null-or-.patch new file mode 100644 index 0000000000..40d646c7df --- /dev/null +++ b/meta-oe/recipes-extended/mozjs/mozjs/0001-compare-the-first-character-of-string-to-be-null-or-.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From f36c9476d2816e0d3e61c9e13c22ed73883cb54a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 24 Apr 2017 12:13:43 -0700 | ||
4 | Subject: [PATCH] compare the first character of string to be null or not | ||
5 | |||
6 | Fixes | ||
7 | |||
8 | error: ISO C++ forbids comparison between pointer and integer [-fpermissive] | ||
9 | | if (value[0] == '\0') | ||
10 | | ^~~~ | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | js/src/shell/jsoptparse.cpp | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/js/src/shell/jsoptparse.cpp b/js/src/shell/jsoptparse.cpp | ||
18 | index b49d0a5..612aa00 100644 | ||
19 | --- a/js/src/shell/jsoptparse.cpp | ||
20 | +++ b/js/src/shell/jsoptparse.cpp | ||
21 | @@ -243,7 +243,7 @@ OptionParser::extractValue(size_t argc, char **argv, size_t *i, char **value) | ||
22 | char *eq = strchr(argv[*i], '='); | ||
23 | if (eq) { | ||
24 | *value = eq + 1; | ||
25 | - if (value[0] == '\0') | ||
26 | + if (value[0][0] == '\0') | ||
27 | return error("A value is required for option %.*s", eq - argv[*i], argv[*i]); | ||
28 | return Okay; | ||
29 | } | ||
30 | -- | ||
31 | 2.12.2 | ||
32 | |||
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb index 3424669b8d..6c9920ef41 100644 --- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb +++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb | |||
@@ -2,21 +2,20 @@ SUMMARY = "SpiderMonkey is Mozilla's JavaScript engine written in C/C++" | |||
2 | LICENSE = "MPL-2.0" | 2 | LICENSE = "MPL-2.0" |
3 | LIC_FILES_CHKSUM = "file://../../LICENSE;md5=815ca599c9df247a0c7f619bab123dad" | 3 | LIC_FILES_CHKSUM = "file://../../LICENSE;md5=815ca599c9df247a0c7f619bab123dad" |
4 | 4 | ||
5 | SRC_URI = " \ | 5 | SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/js/${BPN}${PV}.tar.gz \ |
6 | http://ftp.mozilla.org/pub/mozilla.org/js/${BPN}${PV}.tar.gz \ | 6 | file://0001-mozjs17.0.0-fix-the-compile-bug-of-powerpc.patch \ |
7 | file://0001-mozjs17.0.0-fix-the-compile-bug-of-powerpc.patch \ | 7 | file://0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch \ |
8 | file://0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch \ | 8 | file://0002-Move-JS_BYTES_PER_WORD-out-of-config.h.patch;patchdir=../../ \ |
9 | file://0002-Move-JS_BYTES_PER_WORD-out-of-config.h.patch;patchdir=../../ \ | 9 | file://0003-Add-AArch64-support.patch;patchdir=../../ \ |
10 | file://0003-Add-AArch64-support.patch;patchdir=../../ \ | 10 | file://0004-mozbug746112-no-decommit-on-large-pages.patch;patchdir=../../ \ |
11 | file://0004-mozbug746112-no-decommit-on-large-pages.patch;patchdir=../../ \ | 11 | file://0005-aarch64-64k-page.patch;patchdir=../../ \ |
12 | file://0005-aarch64-64k-page.patch;patchdir=../../ \ | 12 | file://0001-regenerate-configure.patch;patchdir=../../ \ |
13 | file://0001-regenerate-configure.patch;patchdir=../../ \ | 13 | file://fix-the-compile-error-of-powerpc64.patch;patchdir=../../ \ |
14 | file://fix-the-compile-error-of-powerpc64.patch;patchdir=../../ \ | 14 | file://fix_milestone_compile_issue.patch \ |
15 | file://fix_milestone_compile_issue.patch \ | 15 | file://0010-fix-cross-compilation-on-i586-targets.patch;patchdir=../../ \ |
16 | file://0010-fix-cross-compilation-on-i586-targets.patch;patchdir=../../ \ | 16 | file://Manually_mmap_heap_memory_esr17.patch;patchdir=../../ \ |
17 | file://0001-add-support-for-big-endian-32bit-ARM.patch;patchdir=../../ \ | 17 | file://0001-compare-the-first-character-of-string-to-be-null-or-.patch;patchdir=../../ \ |
18 | file://Manually_mmap_heap_memory_esr17.patch;patchdir=../../ \ | 18 | " |
19 | " | ||
20 | 19 | ||
21 | SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202" | 20 | SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202" |
22 | SRC_URI[sha256sum] = "321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c172fba" | 21 | SRC_URI[sha256sum] = "321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c172fba" |