summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography-vectors.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb16
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography-vectors_1.4.bb2
3 files changed, 19 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography-vectors.inc b/meta-python/recipes-devtools/python/python-cryptography-vectors.inc
new file mode 100644
index 000000000..62dfbfd34
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography-vectors.inc
@@ -0,0 +1,15 @@
1SUMMARY = "Test vectors for the cryptography package."
2SECTION = "devel/python"
3LICENSE = "Apache-2.0 | BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
5
6DEPENDS = " \
7 ${PYTHON_PN}-cryptography \
8"
9
10SRC_URI[md5sum] = "b8555dfadafc4ecab4ee4650430d9cab"
11SRC_URI[sha256sum] = "0728815ef0c53d67fd437aa5220450a9752d41ecb28108f5df628a092ff466ea"
12
13PYPI_PACKAGE = "cryptography_vectors"
14
15BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb b/meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb
index 0313c81dc..4975278a9 100644
--- a/meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb
@@ -1,14 +1,2 @@
1SUMMARY = "Test vectors for the cryptography package." 1inherit pypi setuptools
2SECTION = "devel/python" 2require python-cryptography-vectors.inc
3LICENSE = "Apache-2.0 | BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
5DEPENDS = "python-cryptography"
6SRCNAME = "cryptography_vectors"
7
8SRC_URI = "https://files.pythonhosted.org/packages/source/c/cryptography-vectors/${SRCNAME}-${PV}.tar.gz"
9S = "${WORKDIR}/${SRCNAME}-${PV}"
10
11SRC_URI[md5sum] = "b8555dfadafc4ecab4ee4650430d9cab"
12SRC_URI[sha256sum] = "0728815ef0c53d67fd437aa5220450a9752d41ecb28108f5df628a092ff466ea"
13
14inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-cryptography-vectors_1.4.bb b/meta-python/recipes-devtools/python/python3-cryptography-vectors_1.4.bb
new file mode 100644
index 000000000..58994ffff
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography-vectors_1.4.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools3
2require python-cryptography-vectors.inc