diff options
-rw-r--r-- | meta-oe/recipes-connectivity/libimobiledevice/files/inline-without-definition.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_git.bb (renamed from meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_1.1.4.bb) | 13 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb | 19 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch | 51 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libimobiledevice/files/fix-parallel-make.patch | 21 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libimobiledevice/libplist_2.0.0.bb (renamed from meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb) | 10 |
6 files changed, 18 insertions, 127 deletions
diff --git a/meta-oe/recipes-connectivity/libimobiledevice/files/inline-without-definition.patch b/meta-oe/recipes-connectivity/libimobiledevice/files/inline-without-definition.patch deleted file mode 100644 index 9a7895fd4..000000000 --- a/meta-oe/recipes-connectivity/libimobiledevice/files/inline-without-definition.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | Fix link error with gcc 5 toolchains | ||
2 | |||
3 | afc.c:258: error: undefined reference to 'debug_buffer' | ||
4 | collect2: error: ld returned 1 exit status | ||
5 | |||
6 | debug.h header was declaring things inline without providing a definition. | ||
7 | Files that included this header then failed to link against the corresponding | ||
8 | external symbol in debug.c, because the linker took the 'inline' keyword | ||
9 | seriously rather than ignoring it. | ||
10 | |||
11 | --- libimobiledevice-1.1.4/src/debug.h.orig 2015-10-03 16:24:08.758740386 -0700 | ||
12 | +++ libimobiledevice-1.1.4/src/debug.h 2015-10-03 16:24:22.706740355 -0700 | ||
13 | @@ -44,14 +44,14 @@ | ||
14 | #define debug_plist(a) | ||
15 | #endif | ||
16 | |||
17 | -LIBIMOBILEDEVICE_INTERNAL inline void debug_info_real(const char *func, | ||
18 | +LIBIMOBILEDEVICE_INTERNAL void debug_info_real(const char *func, | ||
19 | const char *file, | ||
20 | int line, | ||
21 | const char *format, ...); | ||
22 | |||
23 | -LIBIMOBILEDEVICE_INTERNAL inline void debug_buffer(const char *data, const int length); | ||
24 | -LIBIMOBILEDEVICE_INTERNAL inline void debug_buffer_to_file(const char *file, const char *data, const int length); | ||
25 | -LIBIMOBILEDEVICE_INTERNAL inline void debug_plist_real(const char *func, | ||
26 | +LIBIMOBILEDEVICE_INTERNAL void debug_buffer(const char *data, const int length); | ||
27 | +LIBIMOBILEDEVICE_INTERNAL void debug_buffer_to_file(const char *file, const char *data, const int length); | ||
28 | +LIBIMOBILEDEVICE_INTERNAL void debug_plist_real(const char *func, | ||
29 | const char *file, | ||
30 | int line, | ||
31 | plist_t plist); | ||
diff --git a/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_1.1.4.bb b/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_git.bb index 32aca96fd..908b98d8c 100644 --- a/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_1.1.4.bb +++ b/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_git.bb | |||
@@ -7,17 +7,16 @@ LIC_FILES_CHKSUM = "\ | |||
7 | 7 | ||
8 | HOMEPAGE ="http://www.libimobiledevice.org/" | 8 | HOMEPAGE ="http://www.libimobiledevice.org/" |
9 | 9 | ||
10 | DEPENDS = "libplist usbmuxd libtasn1 gnutls libgcrypt" | 10 | DEPENDS = "libplist usbmuxd libusbmuxd libtasn1 gnutls libgcrypt" |
11 | 11 | ||
12 | SRC_URI = " \ | 12 | SRCREV = "fb71aeef10488ed7b0e60a1c8a553193301428c0" |
13 | http://www.libimobiledevice.org/downloads/libimobiledevice-${PV}.tar.bz2 \ | 13 | PV = "1.2.0+git${SRCPV}" |
14 | SRC_URI = "\ | ||
15 | git://github.com/libimobiledevice/libimobiledevice;protocol=https \ | ||
14 | file://configure-fix-largefile.patch \ | 16 | file://configure-fix-largefile.patch \ |
15 | file://inline-without-definition.patch \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | SRC_URI[md5sum] = "3f28cbc6a2e30d34685049c0abde5183" | 19 | S = "${WORKDIR}/git" |
19 | SRC_URI[sha256sum] = "67499cfaa6172f566ee6b0783605acffe484fb7ddc3b09881ab7ac58667ee5b8" | ||
20 | |||
21 | inherit autotools pkgconfig | 20 | inherit autotools pkgconfig |
22 | 21 | ||
23 | EXTRA_OECONF = " --without-cython " | 22 | EXTRA_OECONF = " --without-cython " |
diff --git a/meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb b/meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb index 4365aa4bc..728423432 100644 --- a/meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb +++ b/meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb | |||
@@ -1,24 +1,21 @@ | |||
1 | DESCRIPTION = "This daemon is in charge of multiplexing connections over USB to an iPhone or iPod touch." | 1 | DESCRIPTION = "This daemon is in charge of multiplexing connections over USB to an iPhone or iPod touch." |
2 | LICENSE = "GPLv3 & GPLv2 & LGPLv2.1" | 2 | LICENSE = "GPLv3 & GPLv2 & LGPLv2.1" |
3 | LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=ebb5c50ab7cab4baeffba14977030c07 \ | 3 | LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=ebb5c50ab7cab4baeffba14977030c07 \ |
4 | file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ | 4 | file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504" |
5 | file://COPYING.LGPLv2.1;md5=6ab17b41640564434dda85c06b7124f7" | ||
6 | 5 | ||
7 | DEPENDS = "udev libusb1" | 6 | DEPENDS = "udev libusb1 libplist" |
8 | 7 | ||
9 | inherit cmake pkgconfig gitpkgv | 8 | inherit autotools pkgconfig gitpkgv systemd |
10 | 9 | ||
11 | PKGV = "${GITPKGVTAG}" | 10 | PKGV = "${GITPKGVTAG}" |
12 | 11 | ||
13 | SRCREV = "919587580c5e77f3936f3432115d2e10c7bac7c5" | 12 | SRCREV = "ee85938c21043ef5f7cd4dfbc7677f385814d4d8" |
14 | SRC_URI = "git://git.sukimashita.com/usbmuxd.git;protocol=http" | 13 | SRC_URI = "git://github.com/libimobiledevice/usbmuxd;protocol=https" |
15 | 14 | ||
16 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
17 | 16 | ||
18 | FILES_${PN} += "${base_libdir}/udev/rules.d/" | 17 | EXTRA_OECONF += "--without-preflight" |
19 | 18 | ||
20 | # fix usbmuxd installing files to /usr/lib64 on 64bit hosts: | 19 | FILES_${PN} += "${base_libdir}/udev/rules.d/" |
21 | EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}" | ||
22 | 20 | ||
23 | PACKAGECONFIG ??= "" | 21 | SYSTEMD_SERVICE_${PN} = "usbmuxd.service" |
24 | PACKAGECONFIG[plist] = "-DWANT_PLIST=1,-DWANT_PLIST=0,libplist" | ||
diff --git a/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch b/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch deleted file mode 100644 index f8114a063..000000000 --- a/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | From ad1be542b87b3186f8ef7bee2c594daefe5bb4c8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 18 Oct 2016 21:31:40 +0000 | ||
4 | Subject: [PATCH] Fix warnings found with clang | ||
5 | |||
6 | | /mnt/oe/openembedded-core/build/workspace/sources/libplist/src/base64.c:107:12: error: non-void function 'base64decode' should return a value [-Wreturn-type] | ||
7 | | if (!buf) return; | ||
8 | | ^ | ||
9 | | /mnt/oe/openembedded-core/build/workspace/sources/libplist/src/base64.c:109:16: error: non-void function 'base64decode' should return a value [-Wreturn-type] | ||
10 | | if (len <= 0) return; | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | libcnary/node.c | 2 +- | ||
17 | src/base64.c | 4 ++-- | ||
18 | 2 files changed, 3 insertions(+), 3 deletions(-) | ||
19 | |||
20 | diff --git a/libcnary/node.c b/libcnary/node.c | ||
21 | index 1f9f669..d6f3f63 100644 | ||
22 | --- a/libcnary/node.c | ||
23 | +++ b/libcnary/node.c | ||
24 | @@ -104,7 +104,7 @@ int node_detach(node_t* parent, node_t* child) { | ||
25 | |||
26 | int node_insert(node_t* parent, unsigned int index, node_t* child) | ||
27 | { | ||
28 | - if (!parent || !child) return; | ||
29 | + if (!parent || !child) return -1; | ||
30 | child->isLeaf = TRUE; | ||
31 | child->isRoot = FALSE; | ||
32 | child->parent = parent; | ||
33 | diff --git a/src/base64.c b/src/base64.c | ||
34 | index 65c6061..531a06a 100644 | ||
35 | --- a/src/base64.c | ||
36 | +++ b/src/base64.c | ||
37 | @@ -104,9 +104,9 @@ static int base64decode_block(unsigned char *target, const char *data, size_t da | ||
38 | |||
39 | unsigned char *base64decode(const char *buf, size_t *size) | ||
40 | { | ||
41 | - if (!buf) return; | ||
42 | + if (!buf) return 0; | ||
43 | size_t len = strlen(buf); | ||
44 | - if (len <= 0) return; | ||
45 | + if (len <= 0) return 0; | ||
46 | unsigned char *outbuf = (unsigned char*)malloc((len/4)*3+3); | ||
47 | |||
48 | unsigned char *line; | ||
49 | -- | ||
50 | 1.9.1 | ||
51 | |||
diff --git a/meta-oe/recipes-extended/libimobiledevice/files/fix-parallel-make.patch b/meta-oe/recipes-extended/libimobiledevice/files/fix-parallel-make.patch deleted file mode 100644 index f6ef6f4f8..000000000 --- a/meta-oe/recipes-extended/libimobiledevice/files/fix-parallel-make.patch +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | From 335b25febd4c864ad0ac08479f5cd43fc21b7d73 Mon Sep 17 00:00:00 2001 | ||
2 | From: Nikias Bassen | ||
3 | Date: Mon, 09 Jul 2012 21:17:15 +0000 | ||
4 | Subject: Fix building with parallel build makeopts | ||
5 | |||
6 | --- | ||
7 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
8 | index 0bad840..155994e 100644 | ||
9 | --- a/CMakeLists.txt | ||
10 | +++ b/CMakeLists.txt | ||
11 | @@ -57,6 +57,8 @@ ADD_SUBDIRECTORY( plutil ) | ||
12 | ADD_SUBDIRECTORY( include ) | ||
13 | ADD_SUBDIRECTORY( test ) | ||
14 | |||
15 | +ADD_DEPENDENCIES( plist libcnary ) | ||
16 | + | ||
17 | IF ( SWIG_FOUND AND PYTHONLIBS_FOUND AND PYTHONINTERP_FOUND ) | ||
18 | ADD_SUBDIRECTORY( swig ) | ||
19 | ENDIF ( SWIG_FOUND AND PYTHONLIBS_FOUND AND PYTHONINTERP_FOUND ) | ||
20 | -- | ||
21 | cgit v0.9.0.2 | ||
diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_2.0.0.bb index f78979619..43c1fd5ca 100644 --- a/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb +++ b/meta-oe/recipes-extended/libimobiledevice/libplist_2.0.0.bb | |||
@@ -6,15 +6,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \ | |||
6 | 6 | ||
7 | DEPENDS = "libxml2 glib-2.0 swig python" | 7 | DEPENDS = "libxml2 glib-2.0 swig python" |
8 | 8 | ||
9 | inherit cmake pkgconfig | 9 | inherit autotools pkgconfig pythonnative |
10 | 10 | ||
11 | SRC_URI = "http://www.libimobiledevice.org/downloads/libplist-${PV}.tar.bz2 \ | 11 | SRCREV = "62ec804736435fa34e37e66e228e17e2aacee1d7" |
12 | file://fix-parallel-make.patch \ | 12 | SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https \ |
13 | file://0001-Fix-warnings-found-with-clang.patch \ | ||
14 | " | 13 | " |
15 | 14 | ||
16 | SRC_URI[md5sum] = "2a9e0258847d50f9760dc3ece25f4dc6" | 15 | S = "${WORKDIR}/git" |
17 | SRC_URI[sha256sum] = "a418da3880308199b74766deef2a760a9b169b81a868a6a9032f7614e20500ec" | ||
18 | 16 | ||
19 | do_install_append () { | 17 | do_install_append () { |
20 | if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then | 18 | if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then |