summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/spdlog/files/0001-Enable-use-of-external-fmt-library.patch68
-rw-r--r--meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb (renamed from meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb)5
2 files changed, 2 insertions, 71 deletions
diff --git a/meta-oe/recipes-support/spdlog/files/0001-Enable-use-of-external-fmt-library.patch b/meta-oe/recipes-support/spdlog/files/0001-Enable-use-of-external-fmt-library.patch
deleted file mode 100644
index 98c342fec..000000000
--- a/meta-oe/recipes-support/spdlog/files/0001-Enable-use-of-external-fmt-library.patch
+++ /dev/null
@@ -1,68 +0,0 @@
1Author: Nilesh Patra <npatra974@gmail.com>
2Description: Use external libfmt by default
3Last-Changed: Sun, May, 14 2020
4Forwarded: not-needed
5--- a/CMakeLists.txt
6+++ b/CMakeLists.txt
7@@ -87,7 +87,7 @@ option(SPDLOG_BUILD_WARNINGS "Enable com
8
9 # install options
10 option(SPDLOG_INSTALL "Generate the install target" ${SPDLOG_MASTER_PROJECT})
11-option(SPDLOG_FMT_EXTERNAL "Use external fmt library instead of bundled" OFF)
12+option(SPDLOG_FMT_EXTERNAL "Use external fmt library instead of bundled" ON)
13 option(SPDLOG_FMT_EXTERNAL_HO "Use external fmt header-only library instead of bundled" OFF)
14 option(SPDLOG_NO_EXCEPTIONS "Compile with -fno-exceptions. Call abort() on any spdlog exceptions" OFF)
15
16--- a/include/spdlog/tweakme.h
17+++ b/include/spdlog/tweakme.h
18@@ -71,7 +71,7 @@
19 // In this case spdlog will try to include <fmt/format.h> so set your -I flag
20 // accordingly.
21 //
22-// #define SPDLOG_FMT_EXTERNAL
23+#define SPDLOG_FMT_EXTERNAL 1
24 ///////////////////////////////////////////////////////////////////////////////
25
26 ///////////////////////////////////////////////////////////////////////////////
27--- a/include/spdlog/fmt/bin_to_hex.h
28+++ b/include/spdlog/fmt/bin_to_hex.h
29@@ -5,6 +5,7 @@
30
31 #pragma once
32
33+#include <spdlog/tweakme.h>
34 #include <cctype>
35 #include <spdlog/common.h>
36
37--- a/include/spdlog/fmt/fmt.h
38+++ b/include/spdlog/fmt/fmt.h
39@@ -4,7 +4,7 @@
40 //
41
42 #pragma once
43-
44+#include <spdlog/tweakme.h>
45 //
46 // Include a bundled header-only copy of fmtlib or an external one.
47 // By default spdlog include its own copy.
48--- a/include/spdlog/fmt/ostr.h
49+++ b/include/spdlog/fmt/ostr.h
50@@ -7,7 +7,7 @@
51 //
52 // include bundled or external copy of fmtlib's ostream support
53 //
54-
55+#include <spdlog/tweakme.h>
56 #if !defined(SPDLOG_FMT_EXTERNAL)
57 # ifdef SPDLOG_HEADER_ONLY
58 # ifndef FMT_HEADER_ONLY
59--- a/src/fmt.cpp
60+++ b/src/fmt.cpp
61@@ -6,6 +6,7 @@
62 # error Please define SPDLOG_COMPILED_LIB to compile this file.
63 #endif
64
65+#include <spdlog/tweakme.h>
66 #if !defined(SPDLOG_FMT_EXTERNAL)
67 # include <spdlog/fmt/bundled/format-inl.h>
68
diff --git a/meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb b/meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb
index d377241ad..d36cfcb84 100644
--- a/meta-oe/recipes-support/spdlog/spdlog_1.9.2.bb
+++ b/meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb
@@ -3,9 +3,8 @@ HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" 4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5 5
6SRCREV = "eb3220622e73a4889eee355ffa37972b3cac3df5" 6SRCREV = "76fb40d95455f249bd70824ecfcae7a8f0930fa3"
7SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x; \ 7SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x"
8 file://0001-Enable-use-of-external-fmt-library.patch"
9 8
10DEPENDS += "fmt" 9DEPENDS += "fmt"
11 10