summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.6.bb23
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb21
2 files changed, 21 insertions, 23 deletions
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.6.bb b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.6.bb
deleted file mode 100644
index 88981e44b..000000000
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.6.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Fluidsynth is a software synthesizer"
2HOMEPAGE = "http://www.fluidsynth.org/"
3SECTION = "libs/multimedia"
4LICENSE = "LGPL-2.0+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e198e9aac94943d0ec29a7dae8c29416"
6
7DEPENDS = "alsa-lib ncurses glib-2.0"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BP}/${BP}.tar.gz"
10SRC_URI[md5sum] = "ae5aca6de824b4173667cbd3a310b263"
11SRC_URI[sha256sum] = "50853391d9ebeda9b4db787efb23f98b1e26b7296dd2bb5d0d96b5bccee2171c"
12
13inherit autotools-brokensep pkgconfig lib_package
14
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
16PACKAGECONFIG[sndfile] = "--enable-libsndfile-support,--disable-libsndfile-support,libsndfile1"
17PACKAGECONFIG[jack] = "--enable-jack-support,--disable-jack-support,jack"
18PACKAGECONFIG[pulseaudio] = "--enable-pulse-support,--disable-pulse-support,pulseaudio"
19PACKAGECONFIG[portaudio] = "--enable-portaudio-support,--disable-portaudio-support,portaudio-v19"
20
21do_configure_prepend () {
22 rm -f ${S}/m4/*
23}
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb
new file mode 100644
index 000000000..ef4c6065f
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Fluidsynth is a software synthesizer"
2HOMEPAGE = "http://www.fluidsynth.org/"
3SECTION = "libs/multimedia"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
6
7DEPENDS = "alsa-lib ncurses glib-2.0"
8
9SRC_URI = "git://github.com/FluidSynth/fluidsynth.git;branch=1.1.x"
10SRCREV = "12e7afe3a806a6b397f28e0ca4bc6bab9ebe7047"
11S = "${WORKDIR}/git"
12
13inherit cmake pkgconfig lib_package
14
15EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
16
17PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
18PACKAGECONFIG[sndfile] = "-Denable-libsndfile-support=ON,-Denable-libsndfile-support=OFF,libsndfile1"
19PACKAGECONFIG[jack] = "-Denable-jack-support=ON,-Denable-jack-support=OFF,jack"
20PACKAGECONFIG[pulseaudio] = "-Denable-pulseaudio=ON,--Denable-pulseaudio=OFF,pulseaudio"
21PACKAGECONFIG[portaudio] = "-Denable-portaudio=ON,-Denable-portaudio=OFF,portaudio-v19"