diff options
-rw-r--r-- | meta-oe/recipes-devtools/openocd/openocd/0001-autosetup-cc-check-tools-check-only-the-name.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/openocd/openocd_git.bb | 1 |
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd/0001-autosetup-cc-check-tools-check-only-the-name.patch b/meta-oe/recipes-devtools/openocd/openocd/0001-autosetup-cc-check-tools-check-only-the-name.patch new file mode 100644 index 0000000000..165c658d08 --- /dev/null +++ b/meta-oe/recipes-devtools/openocd/openocd/0001-autosetup-cc-check-tools-check-only-the-name.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 29e8dfae4593c91f11d7ea31a4722a6d82f6c950 Mon Sep 17 00:00:00 2001 | ||
2 | From: Kory Maincent <kory.maincent@bootlin.com> | ||
3 | Date: Wed, 2 Nov 2022 16:39:30 +0100 | ||
4 | Subject: [PATCH] autosetup: cc-check-tools: check only the name of the tool | ||
5 | without its params | ||
6 | |||
7 | Update the tool existence check. Test only the first word of the | ||
8 | args to keep only the executable without its parameters. | ||
9 | |||
10 | Signed-off-by: Kory Maincent <kory.maincent@bootlin.com> | ||
11 | --- | ||
12 | autosetup/cc.tcl | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/jimtcl/autosetup/cc.tcl b/jimtcl/autosetup/cc.tcl | ||
16 | index 585d259..4c87854 100644 | ||
17 | --- a/jimtcl/autosetup/cc.tcl | ||
18 | +++ b/jimtcl/autosetup/cc.tcl | ||
19 | @@ -264,7 +264,7 @@ proc cc-check-tools {args} { | ||
20 | foreach tool $args { | ||
21 | set TOOL [string toupper $tool] | ||
22 | set exe [get-env $TOOL [get-define cross]$tool] | ||
23 | - if {[find-executable {*}$exe]} { | ||
24 | + if {[find-executable {*}[regexp -inline {\S+} $exe]]} { | ||
25 | define $TOOL $exe | ||
26 | continue | ||
27 | } | ||
28 | -- | ||
29 | 2.25.1 | ||
30 | |||
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb index 1503bb6751..06d77b6a9e 100644 --- a/meta-oe/recipes-devtools/openocd/openocd_git.bb +++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb | |||
@@ -9,6 +9,7 @@ SRC_URI = " \ | |||
9 | git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl;branch=master \ | 9 | git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl;branch=master \ |
10 | git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl;branch=master \ | 10 | git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl;branch=master \ |
11 | git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink;branch=master \ | 11 | git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink;branch=master \ |
12 | file://0001-autosetup-cc-check-tools-check-only-the-name.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRCREV_FORMAT = "openocd" | 15 | SRCREV_FORMAT = "openocd" |