summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.17.bb23
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb24
2 files changed, 23 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.17.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.17.bb
new file mode 100644
index 000000000..bcd58914a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.17.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Bindings for the scrypt key derivation function library"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=2ddf47d0ff1849bce3257ccbc1fd275c"
4HOMEPAGE="https://github.com/holgern/py-scrypt"
5
6SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
7
8SRC_URI[sha256sum] = "25b5075f2238be93af1cd574540a5ea01b8547f9b678aa72d22fce22577475ec"
9
10inherit pypi ptest setuptools3 dos2unix
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS_${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/
23}
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
deleted file mode 100644
index 7588fc54b..000000000
--- a/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "Bindings for the scrypt key derivation function library"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc"
4HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview"
5
6SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
7
8SRC_URI[md5sum] = "ae8e3263aa31b040c1f9c7f1e1843a56"
9SRC_URI[sha256sum] = "f8239b2d47fa1d40bc27efd231dc7083695d10c1c2ac51a99380360741e0362d"
10
11inherit pypi ptest setuptools3
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}