summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
new file mode 100644
index 000000000..783a6c707
--- /dev/null
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4DEPENDS = "libusb-compat libftdi"
5RDEPENDS_${PN} = "libusb1"
6
7SRC_URI = "git://repo.or.cz/openocd.git \
8 "
9SRCREV = "cb317eabf2d162365467aeb89b564828e5e6d6f3"
10
11PV = "0.10+gitr${SRCPV}"
12S = "${WORKDIR}/git"
13
14inherit pkgconfig autotools-brokensep gettext
15
16BBCLASSEXTEND += "nativesdk"
17
18EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html "
19
20do_configure() {
21 ./bootstrap
22 oe_runconf ${EXTRA_OECONF}
23}
24
25do_install() {
26 oe_runmake DESTDIR=${D} install
27 if [ -e "${D}${infodir}" ]; then
28 rm -Rf ${D}${infodir}
29 fi
30 if [ -e "${D}${mandir}" ]; then
31 rm -Rf ${D}${mandir}
32 fi
33 if [ -e "${D}${bindir}/.debug" ]; then
34 rm -Rf ${D}${bindir}/.debug
35 fi
36}
37
38FILES_${PN} = " \
39 ${datadir}/openocd/* \
40 ${bindir}/openocd \
41 "
42
43PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
44PACKAGECONFIG ??= "sysfsgpio"