summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd/0001-fix-netcat-openbsd-ftbfs-with-GCC-15.patch51
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd_1.195.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd/0001-fix-netcat-openbsd-ftbfs-with-GCC-15.patch b/meta-networking/recipes-support/netcat/netcat-openbsd/0001-fix-netcat-openbsd-ftbfs-with-GCC-15.patch
new file mode 100644
index 0000000000..c1757d39ad
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat-openbsd/0001-fix-netcat-openbsd-ftbfs-with-GCC-15.patch
@@ -0,0 +1,51 @@
1From 4ca437b129252635e89694446945e69912300ceb Mon Sep 17 00:00:00 2001
2From: "mark.yang" <mark.yang@lge.com>
3Date: Wed, 16 Apr 2025 20:35:46 +0900
4Subject: [PATCH] fix netcat-openbsd: ftbfs with GCC-15
5
6* fix build failure with GCC-15
7netcat.c:1443:41: error: passing argument 2 of 'signal' from incompatible pointer type [-Wincompatible-pointer-types]
8 1443 | signal(SIGALRM, quit);
9 | ^~~~
10 | |
11 | void (*)(void)
12In file included from netcat.c:100:
13TOPDIR/tmp/work/core2-64-oe-linux/netcat-openbsd/1.195/recipe-sysroot/usr/include/signal.h:88:57: note: expected '__sighandler_t' {aka 'void (*)(int)'} but argument is of type 'void (*)(void)'
14 88 | extern __sighandler_t signal (int __sig, __sighandler_t __handler)
15 | ~~~~~~~~~~~~~~~^~~~~~~~~
16netcat.c:241:13: note: 'quit' declared here
17 241 | static void quit();
18 | ^~~~
19TOPDIR/tmp/work/core2-64-oe-linux/netcat-openbsd/1.195/recipe-sysroot/usr/include/signal.h:72:16: note: '__sighandler_t' declared here
20 72 | typedef void (*__sighandler_t) (int);
21 | ^~~~~~~~~~~~~~
22make: *** [Makefile:17: netcat.o] Error 1
23
24Upstream-Status: Submitted [https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1097448]
25Signed-off-by: mark.yang <mark.yang@lge.com>
26---
27 netcat.c | 4 ++--
28 1 file changed, 2 insertions(+), 2 deletions(-)
29
30diff --git a/netcat.c b/netcat.c
31index d70598a..b8ba959 100644
32--- a/netcat.c
33+++ b/netcat.c
34@@ -238,7 +238,7 @@ char *proto_name(int uflag, int dccpflag);
35 static int connect_with_timeout(int fd, const struct sockaddr *sa,
36 socklen_t salen, int ctimeout);
37
38-static void quit();
39+static void quit(int sig);
40
41 int b64_ntop(u_char const *src, size_t srclength, char *target, size_t targsize);
42 int b64_pton(char const *src, u_char *target, size_t targsize);
43@@ -2235,7 +2235,7 @@ usage(int ret)
44 * quit()
45 * handler for a "-q" timeout (exit 0 instead of 1)
46 */
47-static void quit()
48+static void quit(__attribute__((unused)) int sig)
49 {
50 exit(0);
51 }
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd_1.195.bb b/meta-networking/recipes-support/netcat/netcat-openbsd_1.195.bb
index 20ad43a4d5..99ae90aa91 100644
--- a/meta-networking/recipes-support/netcat/netcat-openbsd_1.195.bb
+++ b/meta-networking/recipes-support/netcat/netcat-openbsd_1.195.bb
@@ -10,6 +10,7 @@ do_patch[depends] = "quilt-native:do_populate_sysroot"
10SRC_URI = "http://snapshot.debian.org/archive/debian/20181022T085404Z/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz;name=netcat \ 10SRC_URI = "http://snapshot.debian.org/archive/debian/20181022T085404Z/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz;name=netcat \
11 http://snapshot.debian.org/archive/debian/20181022T085404Z/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}-1.debian.tar.xz;name=netcat-patch;subdir=${BP} \ 11 http://snapshot.debian.org/archive/debian/20181022T085404Z/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}-1.debian.tar.xz;name=netcat-patch;subdir=${BP} \
12 file://0001-bundle-own-base64-encode-decode-functions.patch \ 12 file://0001-bundle-own-base64-encode-decode-functions.patch \
13 file://0001-fix-netcat-openbsd-ftbfs-with-GCC-15.patch \
13 " 14 "
14 15
15SRC_URI[netcat.md5sum] = "219d5e49c45658e229a3bda63063a986" 16SRC_URI[netcat.md5sum] = "219d5e49c45658e229a3bda63063a986"