summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch19
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl_svn.bb42
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch b/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch
new file mode 100644
index 000000000..966a977ee
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch
@@ -0,0 +1,19 @@
1see https://bugs.webkit.org/show_bug.cgi?id=50762
2fixed by:
3http://trac.webkit.org/changeset/78047/trunk/Source/WebCore/CMakeLists.txt
4fix reverted by:
5http://trac.webkit.org/changeset/78057/trunk/Source/WebCore/CMakeLists.txt
6
7so revert revert as we care about webkit-efl and don't care about WinCE
8
9Index: Source/WebCore/CMakeLists.txt
10===================================================================
11--- Source/WebCore/CMakeLists.txt (revision 78042)
12+++ Source/WebCore/CMakeLists.txt (revision 78047)
13@@ -1157,6 +1157,4 @@
14
15 platform/Arena.cpp
16- platform/ContextMenu.cpp
17- platform/ContextMenuItem.cpp
18 platform/ContentType.cpp
19 platform/CrossThreadCopier.cpp
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
new file mode 100644
index 000000000..ee1e18d72
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "Webkit browser engine, EFL edition"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
4 file://JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
5 file://WebKit/efl/ewk/EWebKit.h;endline=20;md5=55ea170b1582797d2c69712de850f2fa \
6"
7
8DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \
9 libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \
10 libxml2 pango eina ecore evas edje"
11
12SRCREV = "79192"
13PV = "1.3.11+svnr${SRCPV}"
14
15SRCREV_FORMAT = "source"
16
17SRC_URI = "\
18 svn://svn.webkit.org/repository/webkit/trunk;module=Source;name=source;proto=http;subdir=src \
19 svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \
20 file://revert.r78057.patch \
21 "
22
23S = "${WORKDIR}/src/Source"
24
25inherit cmake lib_package pkgconfig
26
27# Wants to jump too far for THUMB on armv4t
28# in WebCore::DocTypeStringsHash::doctype_hash_function(char const*, unsigned int)':
29# DocTypeStrings.cpp:(.text._ZN7WebCore18DocTypeStringsHash21doctype_hash_functionEPKcj[WebCore::DocTypeStringsHash::doctype_hash_function(char const*, unsigned int)]+0x12): relocation truncated to fit: R_ARM_THM_CALL against symbol `__gnu_thumb1_case_uhi' defined in .text section in x86_64-linux/usr/armv4t/lib/gcc/arm-oe-linux-gnueabi/4.5.2/libgcc.a(_thumb1_case_uhi.o)
30# the same in WebCore::CSSValueKeywordsHash::value_hash_function(char const*, unsigned int)':
31# WebCore::CSSPropertyNamesHash::propery_hash_function(char const*, unsigned int)':
32# WebCore::ColorDataHash::colordata_hash_function(char const*, unsigned int)':
33ARM_INSTRUCTION_SET = "ARM"
34
35EXTRA_OECMAKE = "-DPORT=Efl -DSHARED_CORE=ON"
36
37LEAD_SONAME = "libewebkit.so"
38PACKAGES =+ "${PN}launcher-dbg ${PN}launcher"
39
40FILES_${PN} += "${datadir}/webkit-1.0/theme/default.edj ${datadir}/ewebkit-0/themes/default.edj"
41FILES_${PN}launcher = "${bindir}/EWebLauncher"
42FILES_${PN}launcher-dbg = "${bindir}/.debug/EWebLauncher"