diff options
3 files changed, 50 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb index f7bf365192..d2d9dcd185 100644 --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | |||
@@ -300,6 +300,7 @@ RDEPENDS:packagegroup-meta-python3 = "\ | |||
300 | python3-pydicti \ | 300 | python3-pydicti \ |
301 | python3-pyephem \ | 301 | python3-pyephem \ |
302 | python3-pyexpect \ | 302 | python3-pyexpect \ |
303 | python3-pyfanotify \ | ||
303 | python3-pyfirmata \ | 304 | python3-pyfirmata \ |
304 | python3-pyflakes \ | 305 | python3-pyflakes \ |
305 | python3-pyhamcrest \ | 306 | python3-pyhamcrest \ |
diff --git a/meta-python/recipes-devtools/python/python3-pyfanotify/0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch b/meta-python/recipes-devtools/python/python3-pyfanotify/0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch new file mode 100644 index 0000000000..933e086265 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyfanotify/0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 9e7894b97ae7afe43a9901b774de5aef401549ac Mon Sep 17 00:00:00 2001 | ||
2 | From: Bartosz Golaszewski <brgl@bgdev.pl> | ||
3 | Date: Thu, 28 Apr 2022 16:32:06 +0200 | ||
4 | Subject: [PATCH] ext: define FNM_EXTMATCH if not already defined | ||
5 | |||
6 | On musl this constant is not defined. Define it locally if not present. | ||
7 | |||
8 | Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> | ||
9 | --- | ||
10 | Upstream-Status: Inappropriate | ||
11 | |||
12 | src/ext.c | 3 +++ | ||
13 | 1 file changed, 3 insertions(+) | ||
14 | |||
15 | diff --git a/src/ext.c b/src/ext.c | ||
16 | index 2ba9a14..98ffc20 100644 | ||
17 | --- a/src/ext.c | ||
18 | +++ b/src/ext.c | ||
19 | @@ -18,6 +18,9 @@ | ||
20 | #include <sys/un.h> | ||
21 | #include <unistd.h> | ||
22 | |||
23 | +#ifndef FNM_EXTMATCH | ||
24 | +#define FNM_EXTMATCH 0 | ||
25 | +#endif | ||
26 | |||
27 | PyDoc_STRVAR(ext__doc__, | ||
28 | "Wrapper for fanotify.\n" | ||
29 | -- | ||
30 | 2.32.0 | ||
31 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pyfanotify_0.1.3.bb b/meta-python/recipes-devtools/python/python3-pyfanotify_0.1.3.bb new file mode 100644 index 0000000000..a7c8f958ec --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyfanotify_0.1.3.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "Python wrapper for Linux fanotify." | ||
2 | HOMEPAGE = "https://github.com/baskiton/pyfanotify" | ||
3 | AUTHOR = "Alexander Baskikh" | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=636a36c9df04efcfacf839b8866d9a37" | ||
7 | |||
8 | SRC_URI += "file://0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch" | ||
9 | SRC_URI[sha256sum] = "0efa73922fd705b4e8f8f0b51cb88198ceef66cc309e1de21674ef44c879029d" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | RDEPENDS:${PN} += " \ | ||
14 | python3-crypt \ | ||
15 | python3-datetime \ | ||
16 | python3-logging \ | ||
17 | python3-multiprocessing \ | ||
18 | " | ||