summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/mosh/mosh/0001-Fix-building-with-libc.patch24
-rw-r--r--meta-oe/recipes-connectivity/mosh/mosh_1.4.0.bb (renamed from meta-oe/recipes-connectivity/mosh/mosh_1.3.2.bb)7
2 files changed, 2 insertions, 29 deletions
diff --git a/meta-oe/recipes-connectivity/mosh/mosh/0001-Fix-building-with-libc.patch b/meta-oe/recipes-connectivity/mosh/mosh/0001-Fix-building-with-libc.patch
deleted file mode 100644
index 100ede17b..000000000
--- a/meta-oe/recipes-connectivity/mosh/mosh/0001-Fix-building-with-libc.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1From efa9e49714b30d7d9128946a2504c93e10d109b5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 29 Jan 2019 12:20:03 -0800
4Subject: [PATCH] Fix building with libc++
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 src/network/network.cc | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/network/network.cc b/src/network/network.cc
13index 26da603..e480853 100644
14--- a/src/network/network.cc
15+++ b/src/network/network.cc
16@@ -335,7 +335,7 @@ bool Connection::try_bind( const char *addr, int port_low, int port_high )
17 }
18 }
19
20- if ( bind( sock(), &local_addr.sa, local_addr_len ) == 0 ) {
21+ if ( ::bind( sock(), &local_addr.sa, local_addr_len ) == 0 ) {
22 set_MTU( local_addr.sa.sa_family );
23 return true;
24 } else if ( i == search_high ) { /* last port to search */
diff --git a/meta-oe/recipes-connectivity/mosh/mosh_1.3.2.bb b/meta-oe/recipes-connectivity/mosh/mosh_1.4.0.bb
index b4b5aa78a..4537a0941 100644
--- a/meta-oe/recipes-connectivity/mosh/mosh_1.3.2.bb
+++ b/meta-oe/recipes-connectivity/mosh/mosh_1.4.0.bb
@@ -14,11 +14,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14 14
15DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter" 15DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter"
16 16
17SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz \ 17SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz"
18 file://0001-Fix-building-with-libc.patch \ 18SRC_URI[sha256sum] = "872e4b134e5df29c8933dff12350785054d2fd2839b5ae6b5587b14db1465ddd"
19 "
20SRC_URI[md5sum] = "5122f4d2b973ab7c38dcdac8c35cb61e"
21SRC_URI[sha256sum] = "da600573dfa827d88ce114e0fed30210689381bbdcff543c931e4d6a2e851216"
22 19
23inherit autotools pkgconfig 20inherit autotools pkgconfig
24 21