summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch45
-rw-r--r--meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch36
-rw-r--r--meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch30
-rw-r--r--meta-oe/recipes-devtools/php/php_8.2.26.bb9
4 files changed, 3 insertions, 117 deletions
diff --git a/meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch b/meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch
deleted file mode 100644
index 2e1e752d61..0000000000
--- a/meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From 1af203e8e385d46ad3e33b1c253b1c564aa99034 Mon Sep 17 00:00:00 2001
2From: Claude Bing <cbing@cybernetics.com>
3Date: Tue, 9 Nov 2021 13:01:55 -0500
4Subject: [PATCH 02/11] build/php.m4: don't unset cache variables
5
6Unsetting prevents cache variable from being passed to configure.
7
8Upstream-Status: Inappropriate [OE-specific]
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11
12update this patch to 7.4.4, acinclude.m4 move to build/php.m4
13Signed-off-by: Changqing Li <changqing.li@windriver.com>
14
15update patch to 8.0.12
16Signed-off-by: Claude Bing <cbing@cybernetics.com>
17---
18 build/php.m4 | 4 ----
19 1 file changed, 4 deletions(-)
20
21diff --git a/build/php.m4 b/build/php.m4
22index 9746ba28f3..93551d9ca7 100644
23--- a/build/php.m4
24+++ b/build/php.m4
25@@ -1568,8 +1568,6 @@ dnl PHP_CHECK_FUNC_LIB
26 dnl
27 AC_DEFUN([PHP_CHECK_FUNC_LIB],[
28 ifelse($2,,:,[
29- unset ac_cv_lib_$2[]_$1
30- unset ac_cv_lib_$2[]___$1
31 unset found
32 AC_CHECK_LIB($2, $1, [found=yes], [
33 AC_CHECK_LIB($2, __$1, [found=yes], [found=no])
34@@ -1604,8 +1602,6 @@ dnl and as a fall back in the specified library. Defines HAVE_func and
35 dnl HAVE_library if found and adds the library to LIBS.
36 dnl
37 AC_DEFUN([PHP_CHECK_FUNC],[
38- unset ac_cv_func_$1
39- unset ac_cv_func___$1
40 unset found
41
42 AC_CHECK_FUNC($1, [found=yes],[ AC_CHECK_FUNC(__$1,[found=yes],[found=no]) ])
43--
442.25.1
45
diff --git a/meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch b/meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch
deleted file mode 100644
index 1aa28e2add..0000000000
--- a/meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From c81d0bd3491a6c6371d9df2f43956d109f984310 Mon Sep 17 00:00:00 2001
2From: Claude Bing <cbing@cybernetics.com>
3Date: Tue, 9 Nov 2021 13:02:29 -0500
4Subject: [PATCH 03/11] php: remove host specific info from header file
5
6Based on:
7https://sources.debian.org/data/main/p/php7.3/7.3.6-1/debian/patches/
8 0036-php-5.4.9-fixheader.patch
9
10Upstream-Status: Inappropriate [not author]
11
12Signed-off-by: Joe Slater <joe.slater@windriver.com>
13Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
14
15update patch to 8.0.12
16Signed-off-by: Claude Bing <cbing@cybernetics.com>
17---
18 configure.ac | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/configure.ac b/configure.ac
22index 1eafd62a44..90c94323aa 100644
23--- a/configure.ac
24+++ b/configure.ac
25@@ -1462,7 +1462,7 @@ PHP_REMOVE_USR_LIB(LDFLAGS)
26 EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
27 EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"
28
29-UNAME=`uname -a | xargs`
30+UNAME=`uname | xargs`
31 PHP_UNAME=${PHP_UNAME:-$UNAME}
32 AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
33 PHP_OS=`uname | xargs`
34--
352.25.1
36
diff --git a/meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch b/meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch
deleted file mode 100644
index d329387e6c..0000000000
--- a/meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 8707720c0aea405f0e06d67354f239232cc823cc Mon Sep 17 00:00:00 2001
2From: Claude Bing <cbing@cybernetics.com>
3Date: Tue, 9 Nov 2021 13:10:02 -0500
4Subject: [PATCH 09/11] php: don't use broken wrapper for mkdir
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8update patch to version 7.4.4
9Signed-off-by: Changqing Li <changqing.li@windriver.com>
10
11update patch to version 8.0.12
12Signed-off-by: Claude Bing <cbing@cybernetics.com>
13Upstream-Status: Pending
14---
15 build/Makefile.global | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/build/Makefile.global b/build/Makefile.global
19index 6566d052de..eb39421f2a 100644
20--- a/build/Makefile.global
21+++ b/build/Makefile.global
22@@ -1,4 +1,4 @@
23-mkinstalldirs = $(top_srcdir)/build/shtool mkdir -p
24+mkinstalldirs = mkdir -p
25 INSTALL = $(top_srcdir)/build/shtool install -c
26 INSTALL_DATA = $(INSTALL) -m 644
27
28--
292.25.1
30
diff --git a/meta-oe/recipes-devtools/php/php_8.2.26.bb b/meta-oe/recipes-devtools/php/php_8.2.26.bb
index b8e96833f6..1f1b91b22f 100644
--- a/meta-oe/recipes-devtools/php/php_8.2.26.bb
+++ b/meta-oe/recipes-devtools/php/php_8.2.26.bb
@@ -13,11 +13,8 @@ DEPENDS:class-native = "zlib-native libxml2-native"
13PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}" 13PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}"
14 14
15SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \ 15SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \
16 file://0002-build-php.m4-don-t-unset-cache-variables.patch \
17 file://0003-php-remove-host-specific-info-from-header-file.patch \
18 file://0004-configure.ac-don-t-include-build-libtool.m4.patch \ 16 file://0004-configure.ac-don-t-include-build-libtool.m4.patch \
19 file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \ 17 file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \
20 file://0009-php-don-t-use-broken-wrapper-for-mkdir.patch \
21 file://0010-iconv-fix-detection.patch \ 18 file://0010-iconv-fix-detection.patch \
22 file://0001-Change-whether-to-inline-XXH3_hashLong_withSecret-to.patch \ 19 file://0001-Change-whether-to-inline-XXH3_hashLong_withSecret-to.patch \
23 " 20 "
@@ -34,6 +31,7 @@ SRC_URI:append:class-target = " \
34 " 31 "
35 32
36S = "${WORKDIR}/php-${PV}" 33S = "${WORKDIR}/php-${PV}"
34
37SRC_URI[sha256sum] = "be57c347d451c905bcb4336832a864d9928dd0e20989b872705fea0ba6476c6b" 35SRC_URI[sha256sum] = "be57c347d451c905bcb4336832a864d9928dd0e20989b872705fea0ba6476c6b"
38 36
39CVE_STATUS_GROUPS += "CVE_STATUS_PHP" 37CVE_STATUS_GROUPS += "CVE_STATUS_PHP"
@@ -52,6 +50,8 @@ inherit autotools pkgconfig python3native gettext multilib_header multilib_scrip
52SSTATE_SCAN_FILES += "phpize" 50SSTATE_SCAN_FILES += "phpize"
53SSTATE_SCAN_FILES += "build-defs.h" 51SSTATE_SCAN_FILES += "build-defs.h"
54 52
53export PHP_UNAME = "Linux"
54
55PHP_LIBDIR = "${libdir}/php${PHP_MAJOR_VERSION}" 55PHP_LIBDIR = "${libdir}/php${PHP_MAJOR_VERSION}"
56 56
57# Common EXTRA_OECONF 57# Common EXTRA_OECONF
@@ -71,7 +71,6 @@ EXTRA_OECONF = "--enable-mbstring \
71 --with-bz2=${STAGING_DIR_TARGET}${exec_prefix} \ 71 --with-bz2=${STAGING_DIR_TARGET}${exec_prefix} \
72 --with-config-file-path=${sysconfdir}/php/apache2-php${PHP_MAJOR_VERSION} \ 72 --with-config-file-path=${sysconfdir}/php/apache2-php${PHP_MAJOR_VERSION} \
73 ${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'ac_cv_c_bigendian_php=no', 'ac_cv_c_bigendian_php=yes', d)} \ 73 ${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'ac_cv_c_bigendian_php=no', 'ac_cv_c_bigendian_php=yes', d)} \
74 ${@bb.utils.contains('PACKAGECONFIG', 'pam', '', 'ac_cv_lib_pam_pam_start=no', d)} \
75 ${COMMON_EXTRA_OECONF} \ 74 ${COMMON_EXTRA_OECONF} \
76" 75"
77 76
@@ -82,8 +81,6 @@ EXTRA_OECONF:append:riscv32 = " --with-pcre-jit=no"
82# see https://github.com/php/php-src/commit/70b02d75f2abe3a292d49c4a4e9e4f850c2fee68 81# see https://github.com/php/php-src/commit/70b02d75f2abe3a292d49c4a4e9e4f850c2fee68
83EXTRA_OECONF:append:riscv32:libc-musl = " --disable-fiber-asm" 82EXTRA_OECONF:append:riscv32:libc-musl = " --disable-fiber-asm"
84 83
85CACHED_CONFIGUREVARS += "ac_cv_func_dlopen=no ac_cv_lib_dl_dlopen=yes"
86
87EXTRA_OECONF:class-native = " \ 84EXTRA_OECONF:class-native = " \
88 --with-zlib=${STAGING_LIBDIR_NATIVE}/.. \ 85 --with-zlib=${STAGING_LIBDIR_NATIVE}/.. \
89 --without-iconv \ 86 --without-iconv \