diff options
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui-ncurses/0003-Simplify-ncurses-finding-module.patch | 35 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb | 1 |
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0003-Simplify-ncurses-finding-module.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0003-Simplify-ncurses-finding-module.patch new file mode 100644 index 0000000000..2520ac46fe --- /dev/null +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0003-Simplify-ncurses-finding-module.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From c2291fe28dc5682f81804941512431642975cf21 Mon Sep 17 00:00:00 2001 | ||
2 | From: Pascal Bach <pascal.bach@siemens.com> | ||
3 | Date: Mon, 29 Oct 2018 18:17:32 +0100 | ||
4 | Subject: [PATCH] Simplify ncurses finding module | ||
5 | |||
6 | CMake will automatically look in the right locations, there is no need to | ||
7 | re-implement the logic with a for loop and NO_DEFAULT_PATH. | ||
8 | |||
9 | It is already done like this to file the headers. | ||
10 | |||
11 | Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/73] | ||
12 | Signed-off-by: Pascal Bach <pascal.bach@siemens.com> | ||
13 | --- | ||
14 | cmake/Modules/FindCurses6.cmake | 8 +++----- | ||
15 | 1 file changed, 3 insertions(+), 5 deletions(-) | ||
16 | |||
17 | diff --git a/cmake/Modules/FindCurses6.cmake b/cmake/Modules/FindCurses6.cmake | ||
18 | index 0bf02c3..e298d5d 100644 | ||
19 | --- a/cmake/Modules/FindCurses6.cmake | ||
20 | +++ b/cmake/Modules/FindCurses6.cmake | ||
21 | @@ -5,11 +5,9 @@ | ||
22 | # CURSES6_LIBRARIES - The libraries needed to use Curses6 | ||
23 | # CURSES6_DEFINITIONS - Compiler switches required for using Curses6 | ||
24 | |||
25 | -FOREACH(path ${CMAKE_LIBRARY_PATH} /usr/${LIB_DIR}) | ||
26 | - FIND_LIBRARY(CURSES6_NCURSESW_LIBRARY NAMES ncursesw PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH) | ||
27 | - FIND_LIBRARY(CURSES6_PANELW_LIBRARY NAMES panelw PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH) | ||
28 | - FIND_LIBRARY(CURSES6_TINFO_LIBRARY NAMES tinfo PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH) | ||
29 | -ENDFOREACH() | ||
30 | +FIND_LIBRARY(CURSES6_NCURSESW_LIBRARY NAMES ncursesw PATH_SUFFIXES ncurses6) | ||
31 | +FIND_LIBRARY(CURSES6_PANELW_LIBRARY NAMES panelw PATH_SUFFIXES ncurses6) | ||
32 | +FIND_LIBRARY(CURSES6_TINFO_LIBRARY NAMES tinfo PATH_SUFFIXES ncurses6) | ||
33 | |||
34 | SET(CURSES6_LIBRARIES ${CURSES6_NCURSESW_LIBRARY} ${CURSES6_PANELW_LIBRARY}) | ||
35 | # tinfo is optional (in 12.1 is not there) | ||
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb index 4fafce1662..18ea2e8285 100644 --- a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb | |||
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | |||
7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ | 7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ |
8 | file://0001-Use-override-consistently.patch \ | 8 | file://0001-Use-override-consistently.patch \ |
9 | file://0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch \ | 9 | file://0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch \ |
10 | file://0003-Simplify-ncurses-finding-module.patch \ | ||
10 | " | 11 | " |
11 | 12 | ||
12 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" | 13 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" |