summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-timeSync-Portable-way-to-print-64bit-time_t.patch54
-rw-r--r--meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.1.5.bb1
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-timeSync-Portable-way-to-print-64bit-time_t.patch b/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-timeSync-Portable-way-to-print-64bit-time_t.patch
new file mode 100644
index 000000000..4a4fae116
--- /dev/null
+++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-timeSync-Portable-way-to-print-64bit-time_t.patch
@@ -0,0 +1,54 @@
1From dcb5d3e5d47b1e01fdcde575badc51825d4f4681 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 3 Jan 2023 13:36:01 -0800
4Subject: [PATCH] timeSync: Portable way to print 64bit time_t
5
6This ensures when 64bit time_t is used on 32bit architectures (
7-D_TIME_BITS=64 ) then it can print it correctly as well.
8
9Fixes
10pllLinux.c:43:20: error: format specifies type 'long' but the argument has type 'long long' [-Werror,-Wformat]
11| prefix, tx->offset, tx->freq, tx->maxerror, tx->esterror,
12| ^~~~~~~~~~
13
14Upstream-Status: Submitted [https://github.com/vmware/open-vm-tools/pull/631]
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 open-vm-tools/services/plugins/timeSync/pllLinux.c | 8 ++++----
18 open-vm-tools/services/plugins/timeSync/slewLinux.c | 2 +-
19 2 files changed, 5 insertions(+), 5 deletions(-)
20
21diff --git a/open-vm-tools/services/plugins/timeSync/pllLinux.c b/open-vm-tools/services/plugins/timeSync/pllLinux.c
22index e9c8e61de..90ba8c63f 100644
23--- a/open-vm-tools/services/plugins/timeSync/pllLinux.c
24+++ b/open-vm-tools/services/plugins/timeSync/pllLinux.c
25@@ -38,10 +38,10 @@
26 static void
27 TimeSyncLogPLLState(const char *prefix, struct timex *tx)
28 {
29- g_debug("%s : off %ld freq %ld maxerr %ld esterr %ld status %d "
30- "const %ld precision %ld tolerance %ld tick %ld\n",
31- prefix, tx->offset, tx->freq, tx->maxerror, tx->esterror,
32- tx->status, tx->constant, tx->precision, tx->tolerance, tx->tick);
33+ g_debug("%s : off %jd freq %jd maxerr %jd esterr %jd status %d "
34+ "const %jd precision %jd tolerance %jd tick %jd\n",
35+ prefix, (intmax_t)tx->offset, (intmax_t)tx->freq, (intmax_t)tx->maxerror, (intmax_t)tx->esterror,
36+ tx->status, (intmax_t)tx->constant, (intmax_t)tx->precision, (intmax_t)tx->tolerance, (intmax_t)tx->tick);
37 }
38
39 /*
40diff --git a/open-vm-tools/services/plugins/timeSync/slewLinux.c b/open-vm-tools/services/plugins/timeSync/slewLinux.c
41index 1ab6e3584..0c304b5d7 100644
42--- a/open-vm-tools/services/plugins/timeSync/slewLinux.c
43+++ b/open-vm-tools/services/plugins/timeSync/slewLinux.c
44@@ -156,6 +156,6 @@ TimeSync_Slew(int64 delta,
45 g_debug("adjtimex failed: %s\n", strerror(errno));
46 return FALSE;
47 }
48- g_debug("time slew start: %ld\n", tx.tick);
49+ g_debug("time slew start: %jd\n", (intmax_t)tx.tick);
50 return TRUE;
51 }
52--
532.39.0
54
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.1.5.bb b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.1.5.bb
index 93d3d59eb..d389d2450 100644
--- a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.1.5.bb
+++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.1.5.bb
@@ -42,6 +42,7 @@ SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https;branch=stabl
42 file://0011-Use-off64_t-instead-of-__off64_t.patch;patchdir=.. \ 42 file://0011-Use-off64_t-instead-of-__off64_t.patch;patchdir=.. \
43 file://0012-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \ 43 file://0012-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \
44 file://0013-open-vm-tools-Correct-include-path-for-poll.h.patch;patchdir=.. \ 44 file://0013-open-vm-tools-Correct-include-path-for-poll.h.patch;patchdir=.. \
45 file://0001-timeSync-Portable-way-to-print-64bit-time_t.patch;patchdir=.. \
45 " 46 "
46 47
47UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)" 48UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)"