summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow/0001-generate-not-static-get_dh-functions.patch33
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow_git.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/openflow/openflow/0001-generate-not-static-get_dh-functions.patch b/meta-networking/recipes-protocols/openflow/openflow/0001-generate-not-static-get_dh-functions.patch
new file mode 100644
index 000000000..4acae80fa
--- /dev/null
+++ b/meta-networking/recipes-protocols/openflow/openflow/0001-generate-not-static-get_dh-functions.patch
@@ -0,0 +1,33 @@
1From 0fe6770b617af7e400abc6f8652c1417d4c3575e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 8 Sep 2018 22:49:15 -0700
4Subject: [PATCH] generate not static get_dh* functions
5
6Fixes build with OpenSSL 1.1.x
7
8Upstream-Status: Pending
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 lib/automake.mk | 5 +++--
13 1 file changed, 3 insertions(+), 2 deletions(-)
14
15diff --git a/lib/automake.mk b/lib/automake.mk
16index bfbeb94..b53909a 100644
17--- a/lib/automake.mk
18+++ b/lib/automake.mk
19@@ -113,8 +113,9 @@ lib/dhparams.c: lib/dh1024.pem lib/dh2048.pem lib/dh4096.pem
20 (echo '#include "lib/dhparams.h"' && \
21 openssl dhparam -C -in $(srcdir)/lib/dh1024.pem -noout && \
22 openssl dhparam -C -in $(srcdir)/lib/dh2048.pem -noout && \
23- openssl dhparam -C -in $(srcdir)/lib/dh4096.pem -noout) \
24- | sed 's/\(get_dh[0-9]*\)()/\1(void)/' > lib/dhparams.c.tmp
25+ openssl dhparam -C -in $(srcdir)/lib/dh4096.pem -noout) | \
26+ sed -e 's/\(get_dh[0-9]*\)()/\1(void)/' \
27+ -e 's/static DH \*get_dh/DH \*get_dh/' > lib/dhparams.c.tmp
28 mv lib/dhparams.c.tmp lib/dhparams.c
29 endif
30
31--
322.18.0
33
diff --git a/meta-networking/recipes-protocols/openflow/openflow_git.bb b/meta-networking/recipes-protocols/openflow/openflow_git.bb
index eceb45e94..b6cef0730 100644
--- a/meta-networking/recipes-protocols/openflow/openflow_git.bb
+++ b/meta-networking/recipes-protocols/openflow/openflow_git.bb
@@ -6,4 +6,5 @@ PV = "1.0+git${SRCPV}"
6SRC_URI += "\ 6SRC_URI += "\
7 file://0001-Check-and-use-strlcpy-from-libc-before-defining-own.patch \ 7 file://0001-Check-and-use-strlcpy-from-libc-before-defining-own.patch \
8 file://0002-lib-netdev-Adjust-header-include-sequence.patch \ 8 file://0002-lib-netdev-Adjust-header-include-sequence.patch \
9 file://0001-generate-not-static-get_dh-functions.patch \
9 " 10 "