summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb b/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb
new file mode 100644
index 000000000..00e5d497b
--- /dev/null
+++ b/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb
@@ -0,0 +1,46 @@
1SUMMARY = "A utility for finding interesting messages in log files"
2DESCRIPTION = "Logwarn searches for interesting messages in log files, \
3 where 'interesting' is defined by a user-supplied list of positive and \
4 negative extended regular expressions. \
5"
6HOMEPAGE = "https://github.com/archiecobbs/logwarn/wiki"
7SECTION = "console/utils"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRC_URI = "https://s3.amazonaws.com/archie-public/${BPN}/${BP}.tar.gz"
13
14SRC_URI[md5sum] = "e544a6230673ea54f7430bf817bb39d8"
15SRC_URI[sha256sum] = "8dbfcf9b28c782ab3bddd6a620d4fb95d1b0ffcbe93276996cdc4800aa9aebd1"
16
17inherit autotools-brokensep
18
19# This directory is NOT volatile.
20#
21lcl_default_state_dir = "${localstatedir}/lib/logwarn"
22
23CFLAGS += '-DDEFAULT_STATE_DIR=\""${lcl_default_state_dir}\""'
24
25
26# Make sure some files exist for autoreconf.
27#
28do_configure_prepend () {
29 touch ${S}/NEWS
30 touch ${S}/ChangeLog
31 touch ${S}/README
32}
33
34# Create a directory for logfile state info, usually under /var/lib.
35#
36do_install_append () {
37 install -d ${D}${lcl_default_state_dir}
38}
39
40# Make a package for the nagios plug-in (script).
41#
42PACKAGES += "${PN}-nagios"
43
44FILES_${PN}-nagios = "${nonarch_libdir}/nagios"
45
46RDEPENDS_${PN}-nagios += "bash"