summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_2.0.5.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb b/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
new file mode 100644
index 000000000..4c086c805
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Filesystem and hardware benchmark and stress tool"
2DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
3stress/hardware verification. It has support for a number of I/O engines, \
4I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
5and much more. It can work on block devices as well as files. fio accepts \
6job descriptions in a simple-to-understand text format. Several example job \
7files are included. fio displays all sorts of I/O performance information."
8HOMEPAGE = "http://freecode.com/projects/fio"
9SECTION = "console/tests"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
12
13DEPENDS = "libaio"
14
15# rev for v2.0.5
16SRCREV = "02efadeb8b05144bcf2fc7796e1da2e7db211d00"
17SRC_URI = "git://git.kernel.dk/fio.git"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
22
23do_install() {
24 oe_runmake install DESTDIR=${D} bindir=${bindir} mandir=${mandir}
25 install -d ${D}/${docdir}/${PN}
26 cp -a ${S}/examples ${D}/${docdir}/${PN}/
27}