summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb b/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
new file mode 100644
index 000000000..504bb9908
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
2HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
6
7SRCNAME = "jsonpatch"
8
9SRC_URI = " \
10 https://pypi.python.org/packages/source/j/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
11"
12
13inherit setuptools
14
15SRC_URI[md5sum] = "76ae3183db5f2a8f85dd7705e9b6f278"
16SRC_URI[sha256sum] = "2e1eb457f9c8dd5dae837ca93c0fe5bd2522c9d44b9b380fb1aab2ab4dec04b1"
17
18RDEPENDS_${PN} += "python-re python-json python-jsonpointer"
19
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21