summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-connectivity/sethdlc/sethdlc.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb b/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
new file mode 100644
index 000000000..3a9692f86
--- /dev/null
+++ b/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "set Linux HDLC packet radio modem driver port information"
2HOMEPAGE = "https://www.kernel.org/pub/linux/utils/net/hdlc"
3LICENSE = "GPLv2 & GPLv2+ "
4LIC_FILES_CHKSUM = "file://Makefile;md5=19aada31930b2be84bf7138420d77263"
5
6
7SRC_URI = "https://www.kernel.org/pub/linux/utils/net/hdlc/${BPN}-1.18.tar.gz \
8"
9SRC_URI[md5sum] = "9016878156a5eadb06c0bae71cc5c9ab"
10SRC_URI[sha256sum] = "21b1e2e1cb0e288b0ec8fcfd9fed449914e0f8e6fc273706bd5b3d4f6ab6b04e"
11
12
13S = "${WORKDIR}/${BPN}-1.18"
14
15DEPENDS="virtual/kernel"
16
17EXTRA_OEMAKE="CROSS_COMPILE=${TARGET_PREFIX} CC='${CC} ${LDFLAGS}' \
18 KERNEL_DIR=${STAGING_KERNEL_DIR} "
19
20do_compile_prepend () {
21 oe_runmake clean
22}
23
24
25do_install() {
26 install -d ${D}/${bindir}
27 install sethdlc ${D}/${bindir}/
28}
29
30FILES_${PN} += "${bindir}/sethdlc"