summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-connectivity/adcli/adcli_0.9.2.bb (renamed from meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb)7
-rw-r--r--meta-networking/recipes-connectivity/adcli/files/0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch39
-rw-r--r--meta-networking/recipes-connectivity/adcli/files/Fixed-build-error-on-musl.patch26
3 files changed, 2 insertions, 70 deletions
diff --git a/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb b/meta-networking/recipes-connectivity/adcli/adcli_0.9.2.bb
index b9fefa858..609282394 100644
--- a/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb
+++ b/meta-networking/recipes-connectivity/adcli/adcli_0.9.2.bb
@@ -4,12 +4,9 @@ DESCRIPTION = "A helper library and tools for Active Directory client operations
4HOMEPAGE = "http://cgit.freedesktop.org/realmd/adcli" 4HOMEPAGE = "http://cgit.freedesktop.org/realmd/adcli"
5SECTION = "net" 5SECTION = "net"
6 6
7SRCREV = "1b1528038e084a9f81ea108cffca9c2707623b9c" 7SRCREV = "8e88e3590a19006362ea8b8dfdc18bb88b3cb3b5"
8 8
9SRC_URI = "git://gitlab.freedesktop.org/realmd/adcli;branch=master \ 9SRC_URI = "git://gitlab.freedesktop.org/realmd/adcli;branch=master"
10 file://Fixed-build-error-on-musl.patch \
11 file://0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch \
12 "
13 10
14S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
15 12
diff --git a/meta-networking/recipes-connectivity/adcli/files/0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch b/meta-networking/recipes-connectivity/adcli/files/0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch
deleted file mode 100644
index 8cc859318..000000000
--- a/meta-networking/recipes-connectivity/adcli/files/0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 98660f57a98f45dbf55414cfde46338019adcc33 Mon Sep 17 00:00:00 2001
2From: Sumit Bose <sbose@redhat.com>
3Date: Wed, 28 Jul 2021 12:55:16 +0200
4Subject: [PATCH] configure: check for ns_get16 and ns_get32 as well
5
6With newer versions of glibc res_query() might ba already available in
7glibc with ns_get16() and ns_get32() still requires libresolv.
8
9Upstream-Status: Backport [https://gitlab.freedesktop.org/realmd/adcli/-/commit/e841ba7513f3f8b6393183d2dea9adcbf7ba2e44]
10Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1984891
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 configure.ac | 6 ++++--
14 1 file changed, 4 insertions(+), 2 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index ebc6cb4..e8775d0 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -98,13 +98,15 @@ AC_SUBST(LDAP_CFLAGS)
21 # -------------------------------------------------------------------
22 # resolv
23
24-AC_MSG_CHECKING(for which library has res_query)
25+AC_MSG_CHECKING([for which library has res_query, ns_get16 and ns_get32])
26 for lib in "" "-lresolv"; do
27 saved_LIBS="$LIBS"
28 LIBS="$LIBS $lib"
29 AC_LINK_IFELSE([
30 AC_LANG_PROGRAM([#include <resolv.h>],
31- [res_query (0, 0, 0, 0, 0)])
32+ [res_query (0, 0, 0, 0, 0);
33+ ns_get32 (NULL);
34+ ns_get16 (NULL);])
35 ],
36 [ AC_MSG_RESULT(${lib:-libc}); have_res_query="yes"; break; ],
37 [ LIBS="$saved_LIBS" ])
38--
392.32.0
diff --git a/meta-networking/recipes-connectivity/adcli/files/Fixed-build-error-on-musl.patch b/meta-networking/recipes-connectivity/adcli/files/Fixed-build-error-on-musl.patch
deleted file mode 100644
index 87bcdfebd..000000000
--- a/meta-networking/recipes-connectivity/adcli/files/Fixed-build-error-on-musl.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 0e64782a45cba9753d1210ee7d7c9dbd42f74ceb Mon Sep 17 00:00:00 2001
2From: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
3Date: Fri, 12 Jul 2019 12:46:54 +0800
4Subject: [PATCH] Fixed build error on musl.
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
8---
9 library/adutil.c | 1 +
10 1 file changed, 1 insertion(+)
11
12diff --git a/library/adutil.c b/library/adutil.c
13index 9b0c47f..b673edd 100644
14--- a/library/adutil.c
15+++ b/library/adutil.c
16@@ -30,6 +30,7 @@
17 #include <assert.h>
18 #include <ctype.h>
19 #include <errno.h>
20+#include <endian.h>
21 #include <stdio.h>
22 #include <stdlib.h>
23 #include <string.h>
24--
252.20.1
26