summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch36
-rw-r--r--meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch51
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_5.1.1.bb (renamed from meta-python/recipes-devtools/python/python-pytest_3.4.2.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest_5.1.1.bb (renamed from meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb)0
5 files changed, 24 insertions, 71 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
index 4c32dfb04..49ef790f0 100644
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -1,13 +1,13 @@
1SUMMARY = "Simple powerful teting with python" 1SUMMARY = "Simple powerful teting with python"
2HOMEPAGE = "http://pytest.org" 2HOMEPAGE = "http://pytest.org"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=640061b8cee64b308a4d2f9f556c12f2"
5 5
6SRC_URI[md5sum] = "1b83a25d45fad893f430fc5031653c56" 6SRC_URI[md5sum] = "662313b4f539f5b66d2fb77791458e82"
7SRC_URI[sha256sum] = "117bad36c1a787e1a8a659df35de53ba05f9f3398fb9e4ac17e80ad5903eb8c5" 7SRC_URI[sha256sum] = "c3d5020755f70c82eceda3feaf556af9a341334414a8eca521a18f463bcead88"
8 8
9SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \ 9SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
10 file://pytest_version_fix.patch " 10 "
11 11
12inherit update-alternatives 12inherit update-alternatives
13 13
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
index 06dfcdfc6..c29fb12de 100644
--- a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
+++ b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
@@ -1,7 +1,7 @@
1From 24a901fd17926e8e05be4ed2e01b0113a2e3a852 Mon Sep 17 00:00:00 2001 1From ff784f4803ab33f5e3389e40d038d52d1e211843 Mon Sep 17 00:00:00 2001
2From: Derek Straka <derek@asterius.io> 2From: Yuan Chao <yuanc.fnst@cn.fujitsu.com>
3Date: Tue, 19 Dec 2017 11:36:39 -0500 3Date: Wed, 28 Aug 2019 16:12:27 +0900
4Subject: [PATCH] [PATCH 1/1] setup.py: remove the setup_requires for 4Subject: [PATCH] [PATCH] setup.py: remove the setup_requires for
5 setuptools-scm 5 setuptools-scm
6 6
7The setup_requires argument forces the download of the egg file for setuptools-scm 7The setup_requires argument forces the download of the egg file for setuptools-scm
@@ -12,21 +12,25 @@ file and in the release tarball it is already correctly created
12Upstream-Status: Inappropriate [oe specific] 12Upstream-Status: Inappropriate [oe specific]
13 13
14Signed-off-by: Derek Straka <derek@asterius.io> 14Signed-off-by: Derek Straka <derek@asterius.io>
15
16Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com>
15--- 17---
16 setup.py | 1 - 18 setup.py | 2 +-
17 1 file changed, 1 deletion(-) 19 1 file changed, 1 insertion(+), 1 deletion(-)
18 20
19diff --git a/setup.py b/setup.py 21diff --git a/setup.py b/setup.py
20index 3eb38ef..1163202 100644 22index adbafb5..75fdd09 100644
21--- a/setup.py 23--- a/setup.py
22+++ b/setup.py 24+++ b/setup.py
23@@ -82,7 +82,6 @@ def main(): 25@@ -19,7 +19,7 @@ INSTALL_REQUIRES = [
24 keywords="test unittest", 26 def main():
25 cmdclass={'test': PyTest}, 27 setup(
26 # the following should be enabled for release 28 use_scm_version={"write_to": "src/_pytest/_version.py"},
27- setup_requires=['setuptools-scm'], 29- setup_requires=["setuptools-scm", "setuptools>=40.0"],
28 python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*', 30+ setup_requires=["setuptools>=40.0"],
29 install_requires=install_requires, 31 package_dir={"": "src"},
30 extras_require=extras_require, 32 extras_require={
33 "testing": [
31-- 34--
322.7.4 352.17.1
36
diff --git a/meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch b/meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch
deleted file mode 100644
index b373d93e8..000000000
--- a/meta-python/recipes-devtools/python/python-pytest/pytest_version_fix.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1Upstream-Status: Inappropriate (OE specific)
2
3python-pytest: remove fetch during do_compile phase
4commit: c974fbf9ebf185552ab65301e07af44f36517abf
5
6introduced an issue by making the version 0.0.0
7this fixes that
8
9Signed-off-by: Armin Kuster <akuster@mvista.com>
10
11Index: pytest-3.2.2/setup.py
12===================================================================
13--- pytest-3.2.2.orig/setup.py
14+++ pytest-3.2.2/setup.py
15@@ -1,5 +1,6 @@
16 import os
17 import sys
18+import re
19 import setuptools
20 import pkg_resources
21 from setuptools import setup, Command
22@@ -22,6 +23,18 @@ classifiers = [
23 with open('README.rst') as fd:
24 long_description = fd.read()
25
26+def read(*names, **kwargs):
27+ with open(os.path.join( *names), 'r') as fp:
28+ return fp.read()
29+
30+def find_version(*file_paths):
31+ version_file = read(*file_paths)
32+ version_match = re.search(r"^version = ['\']([^'\"]*)['\']",
33+ version_file, re.M)
34+
35+ if version_match:
36+ return version_match.group(1)
37+ raise RuntimeError("Unable to find version string.")
38
39 def get_environment_marker_support_level():
40 """
41@@ -59,9 +72,7 @@ def main():
42 name='pytest',
43 description='pytest: simple powerful testing with Python',
44 long_description=long_description,
45- use_scm_version={
46- 'write_to': '_pytest/_version.py',
47- },
48+ version=find_version("_pytest", "_version.py"),
49 url='http://pytest.org',
50 license='MIT license',
51 platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb b/meta-python/recipes-devtools/python/python-pytest_5.1.1.bb
index 39e50aca9..39e50aca9 100644
--- a/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb
+++ b/meta-python/recipes-devtools/python/python-pytest_5.1.1.bb
diff --git a/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb b/meta-python/recipes-devtools/python/python3-pytest_5.1.1.bb
index eba6632a2..eba6632a2 100644
--- a/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest_5.1.1.bb