summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch40
-rw-r--r--meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20180706.bb8
2 files changed, 47 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch b/meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch
new file mode 100644
index 000000000..cd4291d91
--- /dev/null
+++ b/meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch
@@ -0,0 +1,40 @@
1From 54698856e5602bbd9d61e855814c854a013b4840 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 22 Dec 2018 18:47:45 -0800
4Subject: [PATCH] Add OpenEmbedded cross compile case
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 genconfig.sh | 11 +++++++++++
10 1 file changed, 11 insertions(+)
11
12diff --git a/genconfig.sh b/genconfig.sh
13index dc42462..59922e9 100755
14--- a/genconfig.sh
15+++ b/genconfig.sh
16@@ -98,6 +98,12 @@ if [ -f ../shared/tomato_version ]; then
17 OS_VERSION="Tomato $TOMATO_VER"
18 fi
19
20+# OpenEmbedded special case
21+if [ -f ./os.openembedded ]; then
22+ OS_NAME=OpenEmbedded
23+ OS_VERSION=$(cat ./os.openembedded)
24+fi
25+
26 ${RM} ${CONFIGFILE}
27
28 echo "/* MiniUPnP Project" >> ${CONFIGFILE}
29@@ -318,6 +324,11 @@ case $OS_NAME in
30 echo "#define USE_IFACEWATCHER 1" >> ${CONFIGFILE}
31 FW=netfilter
32 ;;
33+ OpenEmbedded)
34+ OS_URL=http://www.openembedded.org/
35+ echo "#define USE_IFACEWATCHER 1" >> ${CONFIGFILE}
36+ FW=netfilter
37+ ;;
38 AstLinux)
39 OS_URL=http://www.astlinux.org/
40 echo "#define USE_IFACEWATCHER 1" >> ${CONFIGFILE}
diff --git a/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20180706.bb b/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20180706.bb
index d5d9bcf64..ff40daaac 100644
--- a/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20180706.bb
+++ b/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20180706.bb
@@ -12,12 +12,18 @@ inherit autotools gettext pkgconfig systemd
12DEPENDS += "iptables net-tools util-linux libmnl libnetfilter-conntrack" 12DEPENDS += "iptables net-tools util-linux libmnl libnetfilter-conntrack"
13 13
14SRC_URI = "http://miniupnp.tuxfamily.org/files/download.php?file=${P}.tar.gz;downloadfilename=${P}.tar.gz \ 14SRC_URI = "http://miniupnp.tuxfamily.org/files/download.php?file=${P}.tar.gz;downloadfilename=${P}.tar.gz \
15 file://miniupnpd.service" 15 file://miniupnpd.service \
16 file://0001-Add-OpenEmbedded-cross-compile-case.patch \
17 "
16SRC_URI[md5sum] = "a84b3647c871802abeccfc2771e8db21" 18SRC_URI[md5sum] = "a84b3647c871802abeccfc2771e8db21"
17SRC_URI[sha256sum] = "fc2d2fd044d8c3f8d02b63d70489bb35ece836a4fc1b6386865ac8fbe8d8b006" 19SRC_URI[sha256sum] = "fc2d2fd044d8c3f8d02b63d70489bb35ece836a4fc1b6386865ac8fbe8d8b006"
18 20
19IPV6 = "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '--ipv6', '', d)}" 21IPV6 = "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '--ipv6', '', d)}"
20 22
23do_configure_prepend() {
24 echo "${@d.getVar('DISTRO_VERSION')}" > ${S}/os.openembedded
25}
26
21do_compile() { 27do_compile() {
22 cd ${S} 28 cd ${S}
23 CONFIG_OPTIONS="${IPV6} --leasefile --vendorcfg" oe_runmake -f Makefile.linux 29 CONFIG_OPTIONS="${IPV6} --leasefile --vendorcfg" oe_runmake -f Makefile.linux