diff options
-rw-r--r-- | meta-perl/recipes-perl/libcurses/libcurses-perl/0001-testtyp.c-Use-proper-prototype-for-main-function.patch | 40 | ||||
-rw-r--r-- | meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb | 10 |
2 files changed, 48 insertions, 2 deletions
diff --git a/meta-perl/recipes-perl/libcurses/libcurses-perl/0001-testtyp.c-Use-proper-prototype-for-main-function.patch b/meta-perl/recipes-perl/libcurses/libcurses-perl/0001-testtyp.c-Use-proper-prototype-for-main-function.patch new file mode 100644 index 0000000000..ab5af3fa8c --- /dev/null +++ b/meta-perl/recipes-perl/libcurses/libcurses-perl/0001-testtyp.c-Use-proper-prototype-for-main-function.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 01d0904a987ec3d8850ae3b54252c9d3bbe75962 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 30 Aug 2022 15:43:42 -0700 | ||
4 | Subject: [PATCH] testtyp.c: Use proper prototype for main function | ||
5 | |||
6 | Newer compilers like clang-15+ will complain about the prototype | ||
7 | vigorously, and the test will end up failing for this reason instead of | ||
8 | real check it should be failing/passing for. | ||
9 | |||
10 | Fixes | ||
11 | testint.c:11:1: error: type specifier missing, defaults to 'int'; ISO C99 and later do not support implicit int [-Wimplicit-int] | ||
12 | main() { | ||
13 | ^ | ||
14 | int | ||
15 | 1 error generated. | ||
16 | |||
17 | Upstream-Status: Pending | ||
18 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
19 | --- | ||
20 | testtyp.c | 5 +++-- | ||
21 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
22 | |||
23 | diff --git a/testtyp.c b/testtyp.c | ||
24 | index 949c3d4..4042f73 100644 | ||
25 | --- a/testtyp.c | ||
26 | +++ b/testtyp.c | ||
27 | @@ -7,7 +7,8 @@ | ||
28 | #define _XOPEN_SOURCE_EXTENDED 1 /* We expect wide character functions */ | ||
29 | |||
30 | #include "c-config.h" | ||
31 | - | ||
32 | -main() { | ||
33 | +int | ||
34 | +main(int argc, char *argv[]) { | ||
35 | typedef SYM c_sym_t; | ||
36 | + return 0; | ||
37 | } | ||
38 | -- | ||
39 | 2.37.3 | ||
40 | |||
diff --git a/meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb b/meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb index 6a6f012fd7..421823d9cd 100644 --- a/meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb +++ b/meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb | |||
@@ -8,13 +8,19 @@ LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a | |||
8 | 8 | ||
9 | DEPENDS += "perl ncurses " | 9 | DEPENDS += "perl ncurses " |
10 | 10 | ||
11 | SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz" | 11 | SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz \ |
12 | file://0001-testtyp.c-Use-proper-prototype-for-main-function.patch \ | ||
13 | " | ||
12 | 14 | ||
13 | SRC_URI[sha256sum] = "fb9efea8c7b5ed5f8ea5dee49d35252accfc05ee6e75cb9a37ab7c847cd261d7" | 15 | SRC_URI[sha256sum] = "fb9efea8c7b5ed5f8ea5dee49d35252accfc05ee6e75cb9a37ab7c847cd261d7" |
14 | 16 | ||
15 | S = "${WORKDIR}/Curses-${PV}" | 17 | S = "${WORKDIR}/Curses-${PV}" |
16 | 18 | ||
17 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}" | 19 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR} TEST_SYMS_OPTS=-v" |
20 | |||
21 | # enable NCURSES_WIDECHAR=1 only if ENABLE_WIDEC has not been explicitly disabled (e.g. by the distro config). | ||
22 | # When compiling against the ncurses library, NCURSES_WIDECHAR needs to explicitly set to 0 in this case. | ||
23 | CFLAGS:append:libc-musl = "${@' -DNCURSES_WIDECHAR=1' if bb.utils.to_boolean((d.getVar('ENABLE_WIDEC') or 'True')) else ' -DNCURSES_WIDECHAR=0'} -DNCURSES_INTERNALS" | ||
18 | 24 | ||
19 | inherit cpan | 25 | inherit cpan |
20 | 26 | ||