diff options
-rw-r--r-- | meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-bool-reserved-word-error-in-gcc-15.patch | 50 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.64.0.bb | 1 |
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-bool-reserved-word-error-in-gcc-15.patch b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-bool-reserved-word-error-in-gcc-15.patch new file mode 100644 index 0000000000..813efbc62a --- /dev/null +++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-bool-reserved-word-error-in-gcc-15.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | From a811ea6af5296b89ee7c2a358dd4ffd2584429f4 Mon Sep 17 00:00:00 2001 | ||
2 | From: "mark.yang" <mark.yang@lge.com> | ||
3 | Date: Wed, 2 Apr 2025 11:00:27 +0900 | ||
4 | Subject: [PATCH] fix bool reserved word error in gcc 15 | ||
5 | |||
6 | * Fix build error with gcc-15.0.1 | ||
7 | http://errors.yoctoproject.org/Errors/Details/850147/ | ||
8 | srcdir/lib/util/include/bool.h:13:5: error: cannot use keyword 'false' as enumeration constant | ||
9 | 13 | false = 0, | ||
10 | | ^~~~~ | ||
11 | srcdir/lib/util/include/bool.h:13:5: note: 'false' is a keyword with '-std=c23' onwards | ||
12 | srcdir/lib/util/include/bool.h:15:3: error: expected ';', identifier or '(' before 'bool' | ||
13 | 15 | } bool; | ||
14 | | ^~~~ | ||
15 | srcdir/lib/util/include/bool.h:15:3: warning: useless type name in empty declaration | ||
16 | In file included from sleep.c:2: | ||
17 | srcdir/lib/util/include/bool.h:13:5: error: cannot use keyword 'false' as enumeration constant | ||
18 | 13 | false = 0, | ||
19 | | ^~~~~ | ||
20 | srcdir/lib/util/include/bool.h:13:5: note: 'false' is a keyword with '-std=c23' onwards | ||
21 | srcdir/lib/util/include/bool.h:15:3: error: expected ';', identifier or '(' before 'bool' | ||
22 | 15 | } bool; | ||
23 | | ^~~~ | ||
24 | |||
25 | gcc-15 switched to -std=c23 by default. | ||
26 | https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=55e3bd376b2214e200fa76d12b67ff259b06c212 | ||
27 | |||
28 | Upstream-Status: Submitted [https://sourceforge.net/p/xmlrpc-c/discussion/131628/thread/70e626d73a] | ||
29 | Signed-off-by: mark.yang <mark.yang@lge.com> | ||
30 | --- | ||
31 | stable/lib/util/include/bool.h | 2 ++ | ||
32 | 1 file changed, 2 insertions(+) | ||
33 | |||
34 | diff --git a/stable/lib/util/include/bool.h b/stable/lib/util/include/bool.h | ||
35 | index 312477c4..a5e81eb6 100644 | ||
36 | --- a/stable/lib/util/include/bool.h | ||
37 | +++ b/stable/lib/util/include/bool.h | ||
38 | @@ -9,10 +9,12 @@ | ||
39 | /* At least the GNU compiler defines __bool_true_false_are_defined */ | ||
40 | #ifndef __bool_true_false_are_defined | ||
41 | #define __bool_true_false_are_defined | ||
42 | +#if defined __STDC__ && defined __STDC_VERSION__ && __STDC_VERSION__ <= 201710L | ||
43 | typedef enum { | ||
44 | false = 0, | ||
45 | true = 1 | ||
46 | } bool; | ||
47 | #endif | ||
48 | #endif | ||
49 | +#endif | ||
50 | |||
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.64.0.bb b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.64.0.bb index 62ba0f53e6..298c84bb2c 100644 --- a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.64.0.bb +++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.64.0.bb | |||
@@ -9,6 +9,7 @@ SRC_URI = "git://github.com/mirror/xmlrpc-c.git;branch=master;protocol=https \ | |||
9 | file://no-automake.patch \ | 9 | file://no-automake.patch \ |
10 | file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \ | 10 | file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \ |
11 | file://0001-unix-common.mk-Ensuring-Sequential-Execution-of-rm-a.patch \ | 11 | file://0001-unix-common.mk-Ensuring-Sequential-Execution-of-rm-a.patch \ |
12 | file://0001-fix-bool-reserved-word-error-in-gcc-15.patch;striplevel=2 \ | ||
12 | " | 13 | " |
13 | # one more commit after Release 1.64.0 in the Stable series | 14 | # one more commit after Release 1.64.0 in the Stable series |
14 | SRCREV = "8ce36bce2438df9b02fcaafd19efa90a56426601" | 15 | SRCREV = "8ce36bce2438df9b02fcaafd19efa90a56426601" |