summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-decorator.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-decorator_4.0.2.bb22
-rw-r--r--meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb2
3 files changed, 23 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python-decorator.inc b/meta-python/recipes-devtools/python/python-decorator.inc
new file mode 100644
index 000000000..2c230ff26
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-decorator.inc
@@ -0,0 +1,20 @@
1SUMMARY = "Python decorator utilities"
2HOMEPAGE = "http://pypi.python.org/pypi/decorator/"
3DESCRIPTION = "\
4The aim of the decorator module it to simplify the usage of decorators \
5for the average programmer, and to popularize decorators by showing \
6various non-trivial examples. Of course, as all techniques, decorators \
7can be abused and you should not try to solve every problem with a \
8decorator, just because you can."
9
10SECTION = "devel/python"
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41e24e0e235a97e60cdb5c4137fa2cd0"
13
14SRCNAME = "decorator"
15
16SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz"
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
19SRC_URI[md5sum] = "033c9563af492c4ce2680ee6ca481fa7"
20SRC_URI[sha256sum] = "1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206"
diff --git a/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb b/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb
index bda0d713d..f26216846 100644
--- a/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb
+++ b/meta-python/recipes-devtools/python/python-decorator_4.0.2.bb
@@ -1,22 +1,2 @@
1SUMMARY = "Python decorator utilities"
2HOMEPAGE = "http://pypi.python.org/pypi/decorator/"
3DESCRIPTION = "\
4The aim of the decorator module it to simplify the usage of decorators \
5for the average programmer, and to popularize decorators by showing \
6various non-trivial examples. Of course, as all techniques, decorators \
7can be abused and you should not try to solve every problem with a \
8decorator, just because you can."
9
10SECTION = "devel/python"
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41e24e0e235a97e60cdb5c4137fa2cd0"
13
14SRCNAME = "decorator"
15
16SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz"
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
19inherit setuptools 1inherit setuptools
20 2require python-decorator.inc
21SRC_URI[md5sum] = "033c9563af492c4ce2680ee6ca481fa7"
22SRC_URI[sha256sum] = "1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206"
diff --git a/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb b/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb
new file mode 100644
index 000000000..844cbdc9a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-decorator_4.0.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-decorator.inc