summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch28
-rw-r--r--meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb17
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch b/meta-python/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch
new file mode 100644
index 000000000..678f7062b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-wtf/import-simplejson-as-json.patch
@@ -0,0 +1,28 @@
1Upstream-Status: Inappropriate [configuration]
2
3Subject: [PATCH] import simplejson as json
4
5At runtime python-Flask-WTF tries to import json, but the module is not
6available, import simplejson as json solve the issue.
7
8Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
9---
10 flask_wtf/recaptcha/validators.py | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/flask_wtf/recaptcha/validators.py b/flask_wtf/recaptcha/validators.py
14index bcff23d..4a244bb 100644
15--- a/flask_wtf/recaptcha/validators.py
16+++ b/flask_wtf/recaptcha/validators.py
17@@ -8,7 +8,7 @@ from flask import request, current_app
18 from wtforms import ValidationError
19 from werkzeug import url_encode
20 from .._compat import to_bytes, to_unicode
21-import json
22+import simplejson as json
23
24 RECAPTCHA_VERIFY_SERVER = 'https://www.google.com/recaptcha/api/siteverify'
25 RECAPTCHA_ERROR_CODES = {
26--
272.1.4
28
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb b/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb
new file mode 100644
index 000000000..79afaf659
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Simple integration of Flask and WTForms."
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3"
4
5SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e"
6SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e"
7
8SRC_URI += " file://import-simplejson-as-json.patch"
9
10PYPI_PACKAGE = "Flask-WTF"
11
12inherit pypi setuptools
13
14RDEPENDS_${PN} = "\
15 python-wtforms \
16 python-simplejson \
17"