summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-wtforms.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-wtforms_2.1.bb18
2 files changed, 17 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-wtforms.inc b/meta-python/recipes-devtools/python/python-wtforms.inc
new file mode 100644
index 000000000..916697fcf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-wtforms.inc
@@ -0,0 +1,16 @@
1DESCRIPTION = "A flexible forms validation and rendering library for python web development."
2HOMEPAGE = "https://pypi.python.org/pypi/WTForms"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=c459accc90c6ed6a94878c8fe0535be2"
6
7SRC_URI[md5sum] = "6938a541fafd1a1ae2f6b9b88588eef2"
8SRC_URI[sha256sum] = "ffdf10bd1fa565b8233380cb77a304cd36fd55c73023e91d4b803c96bc11d46f"
9
10PYPI_PACKAGE = "WTForms"
11PYPI_PACKAGE_EXT = "zip"
12
13RDEPENDS_${PN} += "\
14 ${PYTHON_PN}-netserver \
15 ${PYTHON_PN}-numbers \
16 "
diff --git a/meta-python/recipes-devtools/python/python-wtforms_2.1.bb b/meta-python/recipes-devtools/python/python-wtforms_2.1.bb
index 5ddcb4883..fdb015e8a 100644
--- a/meta-python/recipes-devtools/python/python-wtforms_2.1.bb
+++ b/meta-python/recipes-devtools/python/python-wtforms_2.1.bb
@@ -1,18 +1,2 @@
1DESCRIPTION = "A flexible forms validation and rendering library for python web development."
2HOMEPAGE = "https://pypi.python.org/pypi/WTForms"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=c459accc90c6ed6a94878c8fe0535be2"
6
7SRC_URI[md5sum] = "6938a541fafd1a1ae2f6b9b88588eef2"
8SRC_URI[sha256sum] = "ffdf10bd1fa565b8233380cb77a304cd36fd55c73023e91d4b803c96bc11d46f"
9
10PYPI_PACKAGE = "WTForms"
11PYPI_PACKAGE_EXT = "zip"
12
13inherit pypi setuptools 1inherit pypi setuptools
14 2require python-wtforms.inc
15RDEPENDS_${PN} += "\
16 ${PYTHON_PN}-netserver \
17 ${PYTHON_PN}-numbers \
18 "