diff options
-rw-r--r-- | meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch | 19 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/blueman/blueman_2.3.2.bb (renamed from meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb) | 7 |
2 files changed, 14 insertions, 12 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch b/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch index a52821915..cc448b4ff 100644 --- a/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch +++ b/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch | |||
@@ -16,14 +16,14 @@ Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | |||
16 | 2 files changed, 7 insertions(+), 1 deletion(-) | 16 | 2 files changed, 7 insertions(+), 1 deletion(-) |
17 | 17 | ||
18 | diff --git a/meson.build b/meson.build | 18 | diff --git a/meson.build b/meson.build |
19 | index bc990cd..a37aacd 100644 | 19 | index e12d0ce6..e84457a5 100644 |
20 | --- a/meson.build | 20 | --- a/meson.build |
21 | +++ b/meson.build | 21 | +++ b/meson.build |
22 | @@ -26,7 +26,12 @@ pkgdatadir = join_paths([prefix, get_option('datadir'), package_name]) | 22 | @@ -26,7 +26,12 @@ pkgdatadir = join_paths([prefix, get_option('datadir'), package_name]) |
23 | bindir = join_paths([prefix, get_option('bindir')]) | 23 | bindir = join_paths([prefix, get_option('bindir')]) |
24 | libexecdir = join_paths([prefix, get_option('libexecdir')]) | 24 | libexecdir = join_paths([prefix, get_option('libexecdir')]) |
25 | schemadir = join_paths([datadir, 'glib-2.0', 'schemas']) | 25 | schemadir = join_paths(['share', 'glib-2.0', 'schemas']) |
26 | -pythondir = join_paths([prefix, python.sysconfig_path('purelib')]) | 26 | -pythondir = pyinstall.get_install_dir() |
27 | +pythoninstalldir = get_option('pythoninstalldir') | 27 | +pythoninstalldir = get_option('pythoninstalldir') |
28 | +if pythoninstalldir != '' | 28 | +if pythoninstalldir != '' |
29 | + pythondir = join_paths([prefix, pythoninstalldir]) | 29 | + pythondir = join_paths([prefix, pythoninstalldir]) |
@@ -34,16 +34,17 @@ index bc990cd..a37aacd 100644 | |||
34 | if get_option('policykit') | 34 | if get_option('policykit') |
35 | have_polkit = 'True' | 35 | have_polkit = 'True' |
36 | diff --git a/meson_options.txt b/meson_options.txt | 36 | diff --git a/meson_options.txt b/meson_options.txt |
37 | index b3e939f..96acbbc 100644 | 37 | index 177d9ab8..3e397d8e 100644 |
38 | --- a/meson_options.txt | 38 | --- a/meson_options.txt |
39 | +++ b/meson_options.txt | 39 | +++ b/meson_options.txt |
40 | @@ -5,5 +5,6 @@ option('pulseaudio', type: 'boolean', value: true, description: 'Enable PulseAud | 40 | @@ -2,6 +2,7 @@ option('runtime_deps_check', type: 'boolean', value: true, description: 'Disable |
41 | option('appindicator', type: 'boolean', value: true, description: 'Enable Libappindicator support') | 41 | option('dhcp-config-path', type: 'string', value: '/etc/dhcp3/dhcpd.conf', description: 'Set dhcp3 server configuration path') |
42 | option('policykit', type: 'boolean', value: true, description: 'Enable policykit support') | ||
43 | option('pulseaudio', type: 'boolean', value: true, description: 'Enable PulseAudio support') | ||
44 | +option('pythoninstalldir', type: 'string', description: 'Path to python site-packages dir relative to ${prefix}') | ||
42 | option('systemdsystemunitdir', type: 'string', description: 'Path to systemd system unit dir relative to ${prefix}') | 45 | option('systemdsystemunitdir', type: 'string', description: 'Path to systemd system unit dir relative to ${prefix}') |
43 | option('systemduserunitdir', type: 'string', description: 'Path to systemd user unit dir relative to ${prefix}') | 46 | option('systemduserunitdir', type: 'string', description: 'Path to systemd user unit dir relative to ${prefix}') |
44 | +option('pythoninstalldir', type: 'string', description: 'Path to python site-packages dir relative to ${prefix}') | ||
45 | option('sendto-plugins', type: 'array', choices: ['Caja', 'Nemo', 'Nautilus'], value: ['Caja', 'Nemo', 'Nautilus'], description: 'Install sendto plugins for various filemanagers') | 47 | option('sendto-plugins', type: 'array', choices: ['Caja', 'Nemo', 'Nautilus'], value: ['Caja', 'Nemo', 'Nautilus'], description: 'Install sendto plugins for various filemanagers') |
46 | option('thunar-sendto', type: 'boolean', value: true, description: 'Install Thunar sendto plugin') | ||
47 | -- | 48 | -- |
48 | 2.33.0 | 49 | 2.34.1 |
49 | 50 | ||
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.3.2.bb index 119752086..eed00fce0 100644 --- a/meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb +++ b/meta-networking/recipes-connectivity/blueman/blueman_2.3.2.bb | |||
@@ -7,14 +7,15 @@ DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native" | |||
7 | inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache | 7 | inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache |
8 | 8 | ||
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
10 | https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \ | 10 | git://github.com/blueman-project/blueman.git;protocol=https;branch=2-3-stable \ |
11 | file://0001-Search-for-cython3.patch \ | 11 | file://0001-Search-for-cython3.patch \ |
12 | file://0002-fix-fail-to-enable-bluetooth.patch \ | 12 | file://0002-fix-fail-to-enable-bluetooth.patch \ |
13 | file://0001-meson-add-pythoninstalldir-option.patch \ | 13 | file://0001-meson-add-pythoninstalldir-option.patch \ |
14 | " | 14 | " |
15 | SRC_URI[sha256sum] = "55d639feeda0b43b18a659e65985213a54b47dcb1348f3b4effb5238db242602" | 15 | S = "${WORKDIR}/git" |
16 | SRCREV = "4275c35ffe372c3b194080726fbe1c99f974360f" | ||
16 | 17 | ||
17 | EXTRA_OEMESON = "-Druntime_deps_check=false -Dappindicator=false -Dpythoninstalldir=${@noprefix('PYTHON_SITEPACKAGES_DIR', d)}" | 18 | EXTRA_OEMESON = "-Druntime_deps_check=false -Dpythoninstalldir=${@noprefix('PYTHON_SITEPACKAGES_DIR', d)}" |
18 | 19 | ||
19 | SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service" | 20 | SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service" |
20 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" | 21 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" |