summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq.inc1
-rw-r--r--meta-networking/recipes-support/dnsmasq/files/parallel-make.patch18
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
index e57ab727e..1955d6fef 100644
--- a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
@@ -11,6 +11,7 @@ SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/${@['archive/', ''][float(d.getV
11 file://init \ 11 file://init \
12 file://dnsmasq.conf \ 12 file://dnsmasq.conf \
13 file://dnsmasq.service \ 13 file://dnsmasq.service \
14 file://parallel-make.patch \
14" 15"
15 16
16inherit update-rc.d systemd 17inherit update-rc.d systemd
diff --git a/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch b/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch
new file mode 100644
index 000000000..3d1040cf3
--- /dev/null
+++ b/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch
@@ -0,0 +1,18 @@
1The dnsmasq target depends on .configured and $(objs). .configured does an rm
2-f *.o. Yet the only thing telling make to build the .configured target before
3the $(objs) target was the order of the dependencies of the dnsmasq target. We
4can't rely on that order when doing a paralllel make build, so add an explicit
5rule to enforce that order.
6
7Signed-off-by: Christopher Larson <chris_larson@mentor.com>
8
9--- dnsmasq-2.68.orig/Makefile
10+++ dnsmasq-2.68/Makefile
11@@ -139,6 +139,8 @@ bloatcheck : $(BUILDDIR)/dnsmasq_baselin
12 @rm -f *.o
13 @touch $@
14
15+$(objs): .configured
16+
17 $(objs:.o=.c) $(hdrs):
18 ln -s $(top)/$(SRC)/$@ .