diff options
-rw-r--r-- | meta-oe/recipes-multimedia/jack/jack/0001-Use-SYS_futex-instead-of-__NR_futex.patch | 62 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/jack/jack_1.19.16.bb (renamed from meta-oe/recipes-multimedia/jack/jack_1.19.14.bb) | 3 |
3 files changed, 81 insertions, 14 deletions
diff --git a/meta-oe/recipes-multimedia/jack/jack/0001-Use-SYS_futex-instead-of-__NR_futex.patch b/meta-oe/recipes-multimedia/jack/jack/0001-Use-SYS_futex-instead-of-__NR_futex.patch new file mode 100644 index 000000000..dd1b7ccfd --- /dev/null +++ b/meta-oe/recipes-multimedia/jack/jack/0001-Use-SYS_futex-instead-of-__NR_futex.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | From 83068f9b71aea16d1ad036fdcc326de1027b5585 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 15 Nov 2020 22:13:29 -0800 | ||
4 | Subject: [PATCH] Use SYS_futex instead of __NR_futex | ||
5 | |||
6 | SYS_futex is expected from system C library. | ||
7 | in glibc (/usr/include/bits/syscall.h defines it in terms of of NR_futex) | ||
8 | rv32 is using 64bit time_t from get go unlike other 32bit architectures | ||
9 | in glibc, therefore it wont have NR_futex defined but just NR_futex_time64 | ||
10 | this aliases it to NR_futex so that SYS_futex is then defined for rv32 | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/jackaudio/jack2/pull/670] | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | linux/JackLinuxFutex.cpp | 10 +++++++--- | ||
16 | 1 file changed, 7 insertions(+), 3 deletions(-) | ||
17 | |||
18 | diff --git a/linux/JackLinuxFutex.cpp b/linux/JackLinuxFutex.cpp | ||
19 | index deff006b..aef99cd2 100644 | ||
20 | --- a/linux/JackLinuxFutex.cpp | ||
21 | +++ b/linux/JackLinuxFutex.cpp | ||
22 | @@ -29,6 +29,10 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. | ||
23 | #include <syscall.h> | ||
24 | #include <linux/futex.h> | ||
25 | |||
26 | +#if !defined(SYS_futex) && defined(SYS_futex_time64) | ||
27 | +#define SYS_futex SYS_futex_time64 | ||
28 | +#endif | ||
29 | + | ||
30 | namespace Jack | ||
31 | { | ||
32 | |||
33 | @@ -67,7 +71,7 @@ bool JackLinuxFutex::Signal() | ||
34 | if (! fFutex->internal) return true; | ||
35 | } | ||
36 | |||
37 | - ::syscall(__NR_futex, fFutex, fFutex->internal ? FUTEX_WAKE_PRIVATE : FUTEX_WAKE, 1, NULL, NULL, 0); | ||
38 | + ::syscall(SYS_futex, fFutex, fFutex->internal ? FUTEX_WAKE_PRIVATE : FUTEX_WAKE, 1, NULL, NULL, 0); | ||
39 | return true; | ||
40 | } | ||
41 | |||
42 | @@ -94,7 +98,7 @@ bool JackLinuxFutex::Wait() | ||
43 | if (__sync_bool_compare_and_swap(&fFutex->futex, 1, 0)) | ||
44 | return true; | ||
45 | |||
46 | - if (::syscall(__NR_futex, fFutex, fFutex->internal ? FUTEX_WAIT_PRIVATE : FUTEX_WAIT, 0, NULL, NULL, 0) != 0 && errno != EWOULDBLOCK) | ||
47 | + if (::syscall(SYS_futex, fFutex, fFutex->internal ? FUTEX_WAIT_PRIVATE : FUTEX_WAIT, 0, NULL, NULL, 0) != 0 && errno != EWOULDBLOCK) | ||
48 | return false; | ||
49 | } | ||
50 | } | ||
51 | @@ -122,7 +126,7 @@ bool JackLinuxFutex::TimedWait(long usec) | ||
52 | if (__sync_bool_compare_and_swap(&fFutex->futex, 1, 0)) | ||
53 | return true; | ||
54 | |||
55 | - if (::syscall(__NR_futex, fFutex, fFutex->internal ? FUTEX_WAIT_PRIVATE : FUTEX_WAIT, 0, &timeout, NULL, 0) != 0 && errno != EWOULDBLOCK) | ||
56 | + if (::syscall(SYS_futex, fFutex, fFutex->internal ? FUTEX_WAIT_PRIVATE : FUTEX_WAIT, 0, &timeout, NULL, 0) != 0 && errno != EWOULDBLOCK) | ||
57 | return false; | ||
58 | } | ||
59 | } | ||
60 | -- | ||
61 | 2.29.2 | ||
62 | |||
diff --git a/meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch b/meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch index dda21a32d..1bdc5adbc 100644 --- a/meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch +++ b/meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 76b8a389268275cc13f3b4e61394d40b24ec56f1 Mon Sep 17 00:00:00 2001 | 1 | From f8cb818ca96fc2a45a04448a51f25a277ec183db Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 15 Jan 2020 20:21:58 -0800 | 3 | Date: Wed, 15 Jan 2020 20:21:58 -0800 |
4 | Subject: [PATCH] example-clients: Use c++ compiler for jack_simdtests | 4 | Subject: [PATCH] example-clients: Use c++ compiler for jack_simdtests |
@@ -12,22 +12,26 @@ x86_64-yoe-linux-ld: example-clients/simdtests.cpp.28.o: undefined reference to | |||
12 | Upstream-Status: Submitted [https://github.com/jackaudio/jack2/pull/536] | 12 | Upstream-Status: Submitted [https://github.com/jackaudio/jack2/pull/536] |
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
14 | --- | 14 | --- |
15 | example-clients/wscript | 2 ++ | 15 | example-clients/wscript | 9 +++++++-- |
16 | 1 file changed, 2 insertions(+) | 16 | 1 file changed, 7 insertions(+), 2 deletions(-) |
17 | 17 | ||
18 | diff --git a/example-clients/wscript b/example-clients/wscript | ||
19 | index a8857aa7..df9435aa 100644 | ||
20 | --- a/example-clients/wscript | 18 | --- a/example-clients/wscript |
21 | +++ b/example-clients/wscript | 19 | +++ b/example-clients/wscript |
22 | @@ -69,6 +69,8 @@ def build(bld): | 20 | @@ -49,10 +49,15 @@ def build(bld): |
21 | else: | ||
22 | use = ['clientlib'] | ||
23 | 23 | ||
24 | + if example_program == 'jack_simdtests': | ||
25 | + ftrs = 'cxx cxxprogram' | ||
26 | + else: | ||
27 | + ftrs = 'c cprogram' | ||
28 | + | ||
24 | if bld.env['IS_MACOSX']: | 29 | if bld.env['IS_MACOSX']: |
25 | prog = bld(features='c cprogram', framework = ['Foundation']) | 30 | - prog = bld(features='c cprogram', framework = ['Foundation']) |
26 | + elif example_program == 'jack_simdtests': | 31 | + prog = bld(features = ftrs, framework = ['Foundation']) |
27 | + prog = bld(features='cxx cxxprogram') | ||
28 | else: | 32 | else: |
29 | prog = bld(features='c cprogram') | 33 | - prog = bld(features='c cprogram') |
34 | + prog = bld(features = ftrs) | ||
30 | prog.includes = os_incdir + ['../common/jack', '../common'] | 35 | prog.includes = os_incdir + ['../common/jack', '../common'] |
31 | -- | 36 | prog.source = example_program_source |
32 | 2.25.0 | 37 | prog.use = use |
33 | |||
diff --git a/meta-oe/recipes-multimedia/jack/jack_1.19.14.bb b/meta-oe/recipes-multimedia/jack/jack_1.19.16.bb index e954341ff..c13d6261c 100644 --- a/meta-oe/recipes-multimedia/jack/jack_1.19.14.bb +++ b/meta-oe/recipes-multimedia/jack/jack_1.19.16.bb | |||
@@ -16,8 +16,9 @@ DEPENDS = "libsamplerate0 libsndfile1 readline" | |||
16 | 16 | ||
17 | SRC_URI = "git://github.com/jackaudio/jack2.git \ | 17 | SRC_URI = "git://github.com/jackaudio/jack2.git \ |
18 | file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \ | 18 | file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \ |
19 | file://0001-Use-SYS_futex-instead-of-__NR_futex.patch \ | ||
19 | " | 20 | " |
20 | SRCREV = "b54a09bf7ef760d81fdb8544ad10e45575394624" | 21 | SRCREV = "5b78c2ef158c2d9ffe09818a7dd80209ed251c5f" |
21 | 22 | ||
22 | S = "${WORKDIR}/git" | 23 | S = "${WORKDIR}/git" |
23 | 24 | ||