summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/kernel-4.18.patch33
-rw-r--r--meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb (renamed from meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.18.bb)8
2 files changed, 5 insertions, 36 deletions
diff --git a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/kernel-4.18.patch b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/kernel-4.18.patch
deleted file mode 100644
index 93eaa3d6c..000000000
--- a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/kernel-4.18.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1Description: Fix build failure with new kernel 4.18
2Author: Gianfranco Costamagna <locutusofborg@debian.org>
3
4Upstream-Status:Pending
5Signed-off-by: Khem Raj <raj.khem@gmail.com>
6Index: vbox_module/vboxsf/utils.c
7===================================================================
8--- vbox_module.orig/vboxsf/utils.c
9+++ vbox_module/vboxsf/utils.c
10@@ -50,7 +50,11 @@ static void sf_timespec_from_ftime(RTTIM
11 RTTimeSpecSetNano(ts, t);
12 }
13 #else /* >= 2.6.0 */
14+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 18, 0)
15 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
16+#else
17+static void sf_ftime_from_timespec(struct timespec64 *tv, RTTIMESPEC *ts)
18+#endif
19 {
20 int64_t t = RTTimeSpecGetNano(ts);
21 int64_t nsec;
22@@ -60,7 +64,11 @@ static void sf_ftime_from_timespec(struc
23 tv->tv_nsec = nsec;
24 }
25
26+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 18, 0)
27 static void sf_timespec_from_ftime(RTTIMESPEC *ts, struct timespec *tv)
28+#else
29+static void sf_timespec_from_ftime(RTTIMESPEC *ts, struct timespec64 *tv)
30+#endif
31 {
32 int64_t t = (int64_t)tv->tv_nsec + (int64_t)tv->tv_sec * 1000000000;
33 RTTimeSpecSetNano(ts, t);
diff --git a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.18.bb b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb
index 2a4cc387f..e394f34c7 100644
--- a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.18.bb
+++ b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb
@@ -13,10 +13,9 @@ VBOX_NAME = "VirtualBox-${PV}"
13 13
14SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/${VBOX_NAME}.tar.bz2 \ 14SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/${VBOX_NAME}.tar.bz2 \
15 file://Makefile.utils \ 15 file://Makefile.utils \
16 file://kernel-4.18.patch \
17" 16"
18SRC_URI[md5sum] = "d8e291525b84569356773eef507c49ce" 17SRC_URI[md5sum] = "c9c2f162ac5f99d28d8c0ca43b19ed01"
19SRC_URI[sha256sum] = "ed0a7efd56c7f39fae79c7ec3321473da412ef0d7914457b66f42679d513efcf" 18SRC_URI[sha256sum] = "5580e875349341a1aabc6d5d2f697d242f277487316faaf1fbe68d9014f788d4"
20 19
21S = "${WORKDIR}/vbox_module" 20S = "${WORKDIR}/vbox_module"
22 21
@@ -25,6 +24,9 @@ export BUILD_TARGET_ARCH_x86-64="amd64"
25 24
26EXTRA_OEMAKE += "KERN_DIR='${WORKDIR}/${KERNEL_VERSION}/build'" 25EXTRA_OEMAKE += "KERN_DIR='${WORKDIR}/${KERNEL_VERSION}/build'"
27 26
27# otherwise 5.2.22 builds just vboxguest
28MAKE_TARGETS = "all"
29
28addtask export_sources before do_patch after do_unpack 30addtask export_sources before do_patch after do_unpack
29 31
30do_export_sources() { 32do_export_sources() {