summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword/0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch74
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb3
2 files changed, 75 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch b/meta-gnome/recipes-gnome/abiword/abiword/0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch
new file mode 100644
index 000000000..595ee8e5a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword/0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch
@@ -0,0 +1,74 @@
1From a83e6f50dbd5efa16fb39efe32b9de370f103130 Mon Sep 17 00:00:00 2001
2From: Hubert Figuiere <hub@figuiere.net>
3Date: Sat, 23 Jan 2016 20:46:02 +0000
4Subject: [PATCH] Bug 13754 - Fix build on gcc-6 (default to C++11).
5
6This is debian bug https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811381
7
8git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/trunk@35182 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
9
10Upstream-Status: Backport
11---
12 plugins/collab/backends/service/xp/RealmProtocol.cpp | 4 ++--
13 plugins/collab/backends/service/xp/soa_soup.cpp | 2 +-
14 plugins/latex/xp/ie_exp_LaTeX.cpp | 2 +-
15 plugins/xslfo/xp/ie_exp_XSL-FO.cpp | 2 +-
16 4 files changed, 5 insertions(+), 5 deletions(-)
17
18diff --git a/plugins/collab/backends/service/xp/RealmProtocol.cpp b/plugins/collab/backends/service/xp/RealmProtocol.cpp
19index fb426eb..347a49c 100644
20--- a/plugins/collab/backends/service/xp/RealmProtocol.cpp
21+++ b/plugins/collab/backends/service/xp/RealmProtocol.cpp
22@@ -6,8 +6,8 @@ namespace protocolv1 {
23
24 #define MAX_PACKET_DATA_SIZE 64*1024*1024
25
26-#define RPV1_PACKET_NONEXISTENT -2
27-#define RPV1_PACKET_VARIABLE -1
28+#define RPV1_PACKET_NONEXISTENT uint32_t(-2)
29+#define RPV1_PACKET_VARIABLE uint32_t(-1)
30
31 static uint32_t body_size[6] = {
32 RPV1_PACKET_NONEXISTENT, /* 0: reserved */
33diff --git a/plugins/collab/backends/service/xp/soa_soup.cpp b/plugins/collab/backends/service/xp/soa_soup.cpp
34index 4b81735..f4f5134 100644
35--- a/plugins/collab/backends/service/xp/soa_soup.cpp
36+++ b/plugins/collab/backends/service/xp/soa_soup.cpp
37@@ -163,7 +163,7 @@ namespace soup_soa {
38
39 static bool _invoke(const std::string& /*url*/, const soa::method_invocation& /*mi*/, SoaSoupSession& sess, std::string& result) {
40 if (!sess.m_session || !sess.m_msg )
41- return soa::GenericPtr();
42+ return false;
43
44 guint status = soup_session_send_message (sess.m_session, sess.m_msg);
45 if (!(SOUP_STATUS_IS_SUCCESSFUL (status) ||
46diff --git a/plugins/latex/xp/ie_exp_LaTeX.cpp b/plugins/latex/xp/ie_exp_LaTeX.cpp
47index 7aaf3a9..8bcc250 100644
48--- a/plugins/latex/xp/ie_exp_LaTeX.cpp
49+++ b/plugins/latex/xp/ie_exp_LaTeX.cpp
50@@ -1330,7 +1330,7 @@ void s_LaTeX_Listener::_outputData(const UT_UCSChar * data, UT_uint32 length)
51 m_pie->write(sBuf.c_str(),sBuf.size());
52 }
53
54-#define SUB(a,who) case a: subst = "\\(\\"who"\\)"; return true;
55+#define SUB(a,who) case a: subst = "\\(\\" who"\\)"; return true;
56 #define SUBd(a,who) case a: subst = who; return true;
57 static bool _convertLettersToSymbols(char c, const char *& subst)
58 {
59diff --git a/plugins/xslfo/xp/ie_exp_XSL-FO.cpp b/plugins/xslfo/xp/ie_exp_XSL-FO.cpp
60index cc5e4e6..957226e 100644
61--- a/plugins/xslfo/xp/ie_exp_XSL-FO.cpp
62+++ b/plugins/xslfo/xp/ie_exp_XSL-FO.cpp
63@@ -1451,7 +1451,7 @@ void s_XSL_FO_Listener::_openSection(PT_AttrPropIndex api)
64 { \
65 UT_UTF8String esc = szValue; \
66 esc.escapeXML(); \
67- buf += " "x"=\""; \
68+ buf += " " x"=\""; \
69 buf += esc.utf8_str(); \
70 buf += "\""; \
71 }
72--
732.5.5
74
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
index 49a2a2f9a..5052b36fc 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
@@ -13,6 +13,7 @@ RCONFLICTS_${PN} = "${PN}-embedded"
13SRC_URI = " \ 13SRC_URI = " \
14 http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \ 14 http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
15 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \ 15 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \
16 file://0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch \
16" 17"
17 18
18LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a" 19LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
@@ -122,5 +123,3 @@ python populate_packages_prepend () {
122} 123}
123 124
124FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt" 125FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"
125
126PNBLACKLIST[abiword] ?= "Depends on broken gtkmathview"