summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.71.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.71.bb b/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.71.bb
new file mode 100644
index 000000000..be0f4b29f
--- /dev/null
+++ b/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.71.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "This package contains the Parser.pm module with friends."
2
3SECTION = "libs"
4LICENSE = "Artistic-1.0 | GPL-1.0+"
5
6LIC_FILES_CHKSUM = "file://README;md5=6c3dacf9f405c7483870ab5f148770c3"
7
8DEPENDS += "perl"
9
10SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/HTML-Parser-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "9128a45893097dfa3bf03301b19c5efe"
13SRC_URI[sha256sum] = "be918b3749d3ff93627f72ee4b825683332ecb4c81c67a3a8d72b0435ffbd802"
14
15S = "${WORKDIR}/HTML-Parser-${PV}"
16
17EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
18
19inherit cpan
20
21do_compile() {
22 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
23 cpan_do_compile
24}
25BBCLASSEXTEND = "native"