diff options
-rw-r--r-- | meta-python/recipes-core/images/meta-python-image-ptest.bb | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-fastjsonschema_2.20.0.bb | 2 |
2 files changed, 4 insertions, 1 deletions
diff --git a/meta-python/recipes-core/images/meta-python-image-ptest.bb b/meta-python/recipes-core/images/meta-python-image-ptest.bb index 002bd7a39e..794b9d1e4d 100644 --- a/meta-python/recipes-core/images/meta-python-image-ptest.bb +++ b/meta-python/recipes-core/images/meta-python-image-ptest.bb | |||
@@ -29,7 +29,8 @@ QB_MEM = "-m 1024" | |||
29 | #QB_MEM:virtclass-mcextend-<pn> = "-m 4096" | 29 | #QB_MEM:virtclass-mcextend-<pn> = "-m 4096" |
30 | # python3-scrypt ptests run into OOMs on RISCV64 qemu | 30 | # python3-scrypt ptests run into OOMs on RISCV64 qemu |
31 | QB_MEM:virtclass-mcextend-python3-scrypt = "-m 2048" | 31 | QB_MEM:virtclass-mcextend-python3-scrypt = "-m 2048" |
32 | QB_MEM:virtclass-mcextend-python3-fastjsonschema = "-m 2048" | 32 | # Needs atleast 5G to avoid OOMs |
33 | QB_MEM:virtclass-mcextend-python3-fastjsonschema = "-m 5120" | ||
33 | QB_MEM:virtclass-mcextend-python3-pillow = "-m 2048" | 34 | QB_MEM:virtclass-mcextend-python3-pillow = "-m 2048" |
34 | 35 | ||
35 | TEST_SUITES = "ping ssh parselogs ptest" | 36 | TEST_SUITES = "ping ssh parselogs ptest" |
diff --git a/meta-python/recipes-devtools/python/python3-fastjsonschema_2.20.0.bb b/meta-python/recipes-devtools/python/python3-fastjsonschema_2.20.0.bb index 0524a73b67..4dd9444a9a 100644 --- a/meta-python/recipes-devtools/python/python3-fastjsonschema_2.20.0.bb +++ b/meta-python/recipes-devtools/python/python3-fastjsonschema_2.20.0.bb | |||
@@ -17,9 +17,11 @@ do_install_ptest() { | |||
17 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | 17 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
18 | } | 18 | } |
19 | 19 | ||
20 | # python3-misc for timeit.py | ||
20 | RDEPENDS:${PN}-ptest += "\ | 21 | RDEPENDS:${PN}-ptest += "\ |
21 | python3-colorama \ | 22 | python3-colorama \ |
22 | python3-jsonschema \ | 23 | python3-jsonschema \ |
24 | python3-misc \ | ||
23 | python3-pylint \ | 25 | python3-pylint \ |
24 | python3-pytest \ | 26 | python3-pytest \ |
25 | python3-pytest-benchmark \ | 27 | python3-pytest-benchmark \ |