summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta-python/recipes-devtools/python/python-sqlalchemy.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-sqlalchemy_0.7.9.bb14
-rwxr-xr-xmeta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb2
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb2
4 files changed, 17 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-sqlalchemy.inc b/meta-python/recipes-devtools/python/python-sqlalchemy.inc
new file mode 100755
index 000000000..471c109f9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sqlalchemy.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d7dba1721bc8ce05d421f7279cb87971"
6
7PYPI_PACKAGE = "SQLAlchemy"
8inherit pypi
9
10SRC_URI[md5sum] = "be5af1bebe595206b71b513a14836e4f"
11SRC_URI[sha256sum] = "701b57d628b9fa1cfb82f10665e7214d5d2db23251ca6f23b91c5f56fcdbdeb5"
12
13RDEPENDS_${PN} += "${PYTHON_PN}-numbers"
diff --git a/meta-python/recipes-devtools/python/python-sqlalchemy_0.7.9.bb b/meta-python/recipes-devtools/python/python-sqlalchemy_0.7.9.bb
deleted file mode 100644
index 43b4b7efa..000000000
--- a/meta-python/recipes-devtools/python/python-sqlalchemy_0.7.9.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=baffc5e5f4804c92fc9be155fed70d41"
6RDEPENDS_${PN} += "python-numbers"
7
8SRCNAME = "SQLAlchemy"
9SRC_URI = "${SOURCEFORGE_MIRROR}/sqlalchemy/${SRCNAME}-${PV}.tar.gz"
10SRC_URI[md5sum] = "c4852d586d95a59fbc9358f4467875d5"
11SRC_URI[sha256sum] = "f7a305ad122144f364ce09a2d9ed5159d5f46ec43650653593e7dfa05d3294a1"
12S = "${WORKDIR}/${SRCNAME}-${PV}"
13
14inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb b/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb
new file mode 100755
index 000000000..53c8fecf7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-sqlalchemy.inc
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb
new file mode 100755
index 000000000..86cf9edde
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-sqlalchemy.inc