summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/dont_try_build_with_SSLv2_when_it_is_not_available.patch20
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb4
2 files changed, 23 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/dont_try_build_with_SSLv2_when_it_is_not_available.patch b/meta-python/recipes-devtools/python/python-m2crypto/dont_try_build_with_SSLv2_when_it_is_not_available.patch
new file mode 100644
index 000000000..526c23fa8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-m2crypto/dont_try_build_with_SSLv2_when_it_is_not_available.patch
@@ -0,0 +1,20 @@
1Upstream-Status: Backport
2https://gitlab.com/m2crypto/m2crypto/commit/ac01b38302474920288c1a9eb63fd35fa8d1db5b
3
4Signed-off-by: Armin Kuster <akuster@mvista.com>
5
6Index: M2Crypto-0.21.1/SWIG/_ssl.i
7===================================================================
8--- M2Crypto-0.21.1.orig/SWIG/_ssl.i
9+++ M2Crypto-0.21.1/SWIG/_ssl.i
10@@ -48,8 +48,10 @@ extern const char *SSL_alert_desc_string
11 %rename(ssl_get_alert_desc_v) SSL_alert_desc_string_long;
12 extern const char *SSL_alert_desc_string_long(int);
13
14+#ifndef OPENSSL_NO_SSL2
15 %rename(sslv2_method) SSLv2_method;
16 extern SSL_METHOD *SSLv2_method(void);
17+#endif
18 %rename(sslv3_method) SSLv3_method;
19 extern SSL_METHOD *SSLv3_method(void);
20 %rename(sslv23_method) SSLv23_method;
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
index 67ec9214a..97a16c645 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
+++ b/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
@@ -7,7 +7,8 @@ LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e" 7LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
8 8
9SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-${PV}.tar.gz \ 9SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-${PV}.tar.gz \
10 file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch" 10 file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \
11 file://dont_try_build_with_SSLv2_when_it_is_not_available.patch"
11 12
12SRC_URI[md5sum] = "f93d8462ff7646397a9f77a2fe602d17" 13SRC_URI[md5sum] = "f93d8462ff7646397a9f77a2fe602d17"
13SRC_URI[sha256sum] = "25b94498505c2d800ee465db0cc1aff097b1615adc3ac042a1c85ceca264fc0a" 14SRC_URI[sha256sum] = "25b94498505c2d800ee465db0cc1aff097b1615adc3ac042a1c85ceca264fc0a"
@@ -18,6 +19,7 @@ inherit setuptools
18 19
19SWIG_FEATURES_x86-64 = "-D__x86_64__" 20SWIG_FEATURES_x86-64 = "-D__x86_64__"
20SWIG_FEATURES ?= "" 21SWIG_FEATURES ?= ""
22SWIG_FEATURES += "-DOPENSSL_NO_SSL2"
21export SWIG_FEATURES 23export SWIG_FEATURES
22 24
23# Get around a problem with swig, but only if the 25# Get around a problem with swig, but only if the