summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-02-28 20:14:19 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-28 11:28:37 -0800
commitfdab9ca9fe1b7407880a4138398a7eb09e319162 (patch)
tree076ff057325cc6891387e11b926d53466c39a113 /meta-xfce
parent4b87fabf1210260e244ba6bb666b2554589702a2 (diff)
downloadmeta-openembedded-fdab9ca9fe1b7407880a4138398a7eb09e319162.tar.gz
xfce4-notifyd: use python3native and depend on python3-packaging-native
* it uses gdbus-codegen from glib-2.0-native which depended on python3-distutils-native until https://lists.openembedded.org/g/openembedded-core/message/196136 but distutils on host was enforced by sanity check only until mickledore with: https://git.openembedded.org/openembedded-core/commit/?id=8e3a5b0709384f2b455a82ac1e8e212686fe4456 so on hosts without distutils this was already failing and the glib-2.0-native change only changes the dependency from distutils to packaging which results in: https://errors.yoctoproject.org/Errors/Details/754995/ gdbus-codegen \ --interface-prefix org.xfce.Notifyd.Log \ --c-namespace Xfce \ --generate-c-code xfce-notify-log-gbus \ --glib-max-allowed 2.68 \ ../../xfce4-notifyd-0.8.2/common/xfce-notify-log-dbus.xml Traceback (most recent call last): File "TOPDIR/build/tmp/work/riscv64-yoe-linux/xfce4-notifyd/0.8.2/recipe-sysroot-native/usr/bin/gdbus-codegen", line 53, in <module> from codegen import codegen_main File "TOPDIR/build/tmp/work/riscv64-yoe-linux/xfce4-notifyd/0.8.2/recipe-sysroot-native/usr/share/glib-2.0/codegen/codegen_main.py", line 29, in <module> from . import dbustypes File "TOPDIR/build/tmp/work/riscv64-yoe-linux/xfce4-notifyd/0.8.2/recipe-sysroot-native/usr/share/glib-2.0/codegen/dbustypes.py", line 22, in <module> from . import utils File "TOPDIR/build/tmp/work/riscv64-yoe-linux/xfce4-notifyd/0.8.2/recipe-sysroot-native/usr/share/glib-2.0/codegen/utils.py", line 22, in <module> import packaging.version ModuleNotFoundError: No module named 'packaging' * packaging probably isn't as wide spread on host distros as old distutils was, so make sure it's available by using python3-native with python3-packaging-native from OE build Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.8.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.8.2.bb b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.8.2.bb
index 7dbd90c18..96cfd32f7 100644
--- a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.8.2.bb
+++ b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.8.2.bb
@@ -10,9 +10,11 @@ DEPENDS = " \
10 libxfce4ui \ 10 libxfce4ui \
11 xfconf \ 11 xfconf \
12 xfce4-panel \ 12 xfce4-panel \
13 python3-packaging-native \
13" 14"
14 15
15inherit xfce-app 16inherit xfce-app
17inherit python3native
16 18
17SRC_URI:append = " file://xfce4-notifyd-get-var-abs-path.patch" 19SRC_URI:append = " file://xfce4-notifyd-get-var-abs-path.patch"
18 20