diff options
author | Ross Burton <ross.burton@intel.com> | 2016-04-22 20:48:52 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-28 10:38:38 +0200 |
commit | f08b75f64ccf52c416a2ebaeb2e27d1e50877583 (patch) | |
tree | 714583f0f25a207e60f003d73419473ef66831f9 /meta-xfce | |
parent | e5c807b77fbe753e28483ae7d58d8a5dec676ace (diff) | |
download | meta-openembedded-f08b75f64ccf52c416a2ebaeb2e27d1e50877583.tar.gz |
meta-xfce: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so
replace all instances with bb.utils.contains().
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb | 4 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb | 8 |
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb index fa38c8af0..81b6771f5 100644 --- a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb +++ b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.4.bb | |||
@@ -18,7 +18,7 @@ EXTRA_OECONF = " \ | |||
18 | --enable-panel-plugins \ | 18 | --enable-panel-plugins \ |
19 | " | 19 | " |
20 | 20 | ||
21 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES','systemd','systemd','',d)}" | 21 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}" |
22 | PACKAGECONFIG[systemd] = "--enable-polkit, --disable-polkit, polkit" | 22 | PACKAGECONFIG[systemd] = "--enable-polkit, --disable-polkit, polkit" |
23 | 23 | ||
24 | PACKAGES += "xfce4-powermanager-plugin" | 24 | PACKAGES += "xfce4-powermanager-plugin" |
@@ -34,7 +34,7 @@ FILES_xfce4-powermanager-plugin = " \ | |||
34 | " | 34 | " |
35 | 35 | ||
36 | RDEPENDS_xfce4-powermanager-plugin = "${PN}" | 36 | RDEPENDS_xfce4-powermanager-plugin = "${PN}" |
37 | RDEPENDS_${PN} = "networkmanager ${@base_contains('DISTRO_FEATURES','systemd','','consolekit',d)}" | 37 | RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}" |
38 | 38 | ||
39 | # xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin | 39 | # xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin |
40 | RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin" | 40 | RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |
diff --git a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb index c8224a16e..d5ed04468 100644 --- a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb +++ b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb | |||
@@ -21,8 +21,8 @@ PV = "4.12.0+git${SRCPV}" | |||
21 | EXTRA_OECONF += "--enable-maintainer-mode --disable-debug" | 21 | EXTRA_OECONF += "--enable-maintainer-mode --disable-debug" |
22 | 22 | ||
23 | PACKAGECONFIG ??= " \ | 23 | PACKAGECONFIG ??= " \ |
24 | ${@base_contains('DISTRO_FEATURES','systemd','datetime-setter','',d)} \ | 24 | ${@bb.utils.contains('DISTRO_FEATURES','systemd','datetime-setter','',d)} \ |
25 | ${@base_contains('DISTRO_FEATURES','alsa','sound-setter', base_contains('DISTRO_FEATURES','pulseaudio','sound-setter','',d),d)} \ | 25 | ${@bb.utils.contains('DISTRO_FEATURES','alsa','sound-setter', bb.utils.contains('DISTRO_FEATURES','pulseaudio','sound-setter','',d),d)} \ |
26 | " | 26 | " |
27 | PACKAGECONFIG[datetime-setter] = "--enable-datetime-settings, --disable-datetime-settings,, tzdata" | 27 | PACKAGECONFIG[datetime-setter] = "--enable-datetime-settings, --disable-datetime-settings,, tzdata" |
28 | PACKAGECONFIG[notify] = "--enable-libnotify,--disable-libnotify,libnotify" | 28 | PACKAGECONFIG[notify] = "--enable-libnotify,--disable-libnotify,libnotify" |
@@ -34,5 +34,5 @@ FILES_${PN} += " \ | |||
34 | " | 34 | " |
35 | 35 | ||
36 | RRECOMMENDS_${PN} += "adwaita-icon-theme" | 36 | RRECOMMENDS_${PN} += "adwaita-icon-theme" |
37 | RRECOMMENDS_${PN} += "${@base_contains('DISTRO_FEATURES','alsa','libcanberra-alsa','',d)}" | 37 | RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','alsa','libcanberra-alsa','',d)}" |
38 | RRECOMMENDS_${PN} += "${@base_contains('DISTRO_FEATURES','pulseaudio','libcanberra-pulse','',d)}" | 38 | RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','pulseaudio','libcanberra-pulse','',d)}" |