summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-02-24 14:33:44 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-25 17:57:15 -0800
commite37bcbc1379cab5c4e7644f1d405498dea7e3f52 (patch)
treebbb3bc7b9515d0833209db23a5074cd5525723e3 /meta-xfce
parent691e76b83a5accb22e112e6aaef2cca00d4318bd (diff)
downloadmeta-openembedded-e37bcbc1379cab5c4e7644f1d405498dea7e3f52.tar.gz
xfce4-sensors-plugin: Change defaults to useful ones
Every time I added xfce4-sensors-plugin to panel xfce4-sensors-plugin suggested sensors not exactly useful. So change defaults: * remove lmsensors * make sysfsacpi work and don't disable it because that's where embedded machines drop useful information Background: Have spent lots of efforts to get Raspi4 cooled properly while running at gouvernor 'performance' and rendering music. Would like to see if it really wears a cool hat [1] [1] https://github.com/schnitzeltony/rpi-cool-hat Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch44
-rw-r--r--meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb3
2 files changed, 45 insertions, 2 deletions
diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch
new file mode 100644
index 000000000..ac1d603b2
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch
@@ -0,0 +1,44 @@
1From 9b7e1beca872ca4a5fce8938c58379103787f79a Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Sun, 23 Feb 2020 22:06:32 +0100
4Subject: [PATCH] Do not check for /sys/class/power_supply - we are cross
5 compiling
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10Upstream-Status: Inappropriate [OE-specific]
11
12Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
13---
14 configure.ac | 12 +-----------
15 1 file changed, 1 insertion(+), 11 deletions(-)
16
17diff --git a/configure.ac b/configure.ac
18index c281af9..60ba0c0 100644
19--- a/configure.ac
20+++ b/configure.ac
21@@ -209,19 +209,9 @@ dnl Check for interface for /sys/class/power_supply to be used
22 AC_ARG_ENABLE([sysfsacpi], [AC_HELP_STRING([--enable-sysfsacpi], [Use /sys/class/power_supply to read your battery value @<:@default=auto@:>@])],
23 [],
24 [
25- enable_sysfsacpi=auto
26+ enable_sysfsacpi=yes
27 ])
28
29-if test x"$enable_sysfsacpi" = x"auto"; then
30- AC_CHECK_FILE([/sys/class/power_supply],
31- [
32- enable_sysfsacpi=yes
33- ],
34- [
35- enable_sysfsacpi=no
36- ])
37-fi
38-
39 if test x"$enable_sysfsacpi" = x"yes"; then
40 AC_DEFINE([HAVE_SYSFS_ACPI], [1], [Define to 1 if /sys/class/power_supply is found])
41 enable_procacpi=yes
42--
432.21.0
44
diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb
index 8b650143f..3fd0ff6cf 100644
--- a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb
+++ b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb
@@ -7,10 +7,10 @@ inherit xfce-panel-plugin
7 7
8SRC_URI[md5sum] = "7327c4c316ebd5d93665e77b432b8d89" 8SRC_URI[md5sum] = "7327c4c316ebd5d93665e77b432b8d89"
9SRC_URI[sha256sum] = "3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112" 9SRC_URI[sha256sum] = "3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112"
10SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
10 11
11EXTRA_OECONF = " \ 12EXTRA_OECONF = " \
12 --disable-procacpi \ 13 --disable-procacpi \
13 --disable-sysfsacpi \
14 --disable-xnvctrl \ 14 --disable-xnvctrl \
15" 15"
16 16
@@ -18,7 +18,6 @@ do_configure_prepend() {
18 sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac 18 sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
19} 19}
20 20
21PACKAGECONFIG ??= "libsensors"
22PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors" 21PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
23PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp" 22PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
24PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat" 23PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"