summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2024-12-19 18:52:23 +0800
committerKhem Raj <raj.khem@gmail.com>2024-12-19 09:41:30 -0800
commit6062a0c9af9d26eb85c8a1e291a483b920b9c6c3 (patch)
tree5177c794c9543e69a7e9c1719b0b48b6b44d0fe8 /meta-xfce
parent093a67bc623d32e20a956434ad09e643ecfe021f (diff)
downloadmeta-openembedded-6062a0c9af9d26eb85c8a1e291a483b920b9c6c3.tar.gz
libxfce4windowing: add recipe
Add recipe for libxfce4windowing 4.20.0 which is required by other xfce4 components such as xfce4-session, xfdesktop etc. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/libxfce4windowing/libxfce4windowing_4.20.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/libxfce4windowing/libxfce4windowing_4.20.0.bb b/meta-xfce/recipes-xfce/libxfce4windowing/libxfce4windowing_4.20.0.bb
new file mode 100644
index 000000000..e16997ca1
--- /dev/null
+++ b/meta-xfce/recipes-xfce/libxfce4windowing/libxfce4windowing_4.20.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Windowing concept abstraction library for X11 and Wayland"
2SECTION = "x11/libs"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=435ed639f84d4585d93824e7da3d85da"
5
6DEPENDS = "xfce4-dev-tools-native libdisplay-info libwnck3"
7
8SRC_URI[sha256sum] = "56f29b1d79606fb00a12c83ef4ece12877d2b22bf1acaaff89537fbe8e939f68"
9
10inherit features_check gobject-introspection gtk-doc xfce
11
12# Currently, X11 is fully supported. Wayland is partially supported
13REQUIRED_DISTRO_FEATURES = "x11"
14
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
16PACKAGECONFIG[wayland] = "--enable-wayland, --disable-wayland, wayland-native"
17
18EXTRA_OECONF = "--enable-x11 \
19 WAYLAND_SCANNER=${STAGING_BINDIR_NATIVE}/wayland-scanner \
20 "
21
22do_compile:prepend() {
23 export GIR_EXTRA_LIBS_PATH=${B}/libxfce4windowing/.libs
24}