summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-06-10 17:08:09 +0200
committerKhem Raj <raj.khem@gmail.com>2018-06-14 08:57:14 -0700
commit5f31db6014082a16c0be8553b6388ff5f12428bd (patch)
tree38bcaaa479dc509a689c032c9455263bd103a9e2 /meta-xfce
parent13f311d88ffda574f3c0e3b70b8fbe3907c5629f (diff)
downloadmeta-openembedded-5f31db6014082a16c0be8553b6388ff5f12428bd.tar.gz
xfce4-panel: upgrade 4.12.2 -> 4.13.3
It is a development release but stoppers could not be found. * Uses GTK3 * Fixes background color in systray panel-plugin Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch42
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch (renamed from meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch)26
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb (renamed from meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.2.bb)13
3 files changed, 18 insertions, 63 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch
deleted file mode 100644
index 9dca3ba57d..0000000000
--- a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From c582338ef4f33b3dc07a2636340d55b9fb530650 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Wed, 17 Feb 2016 00:15:44 +0100
4Subject: [PATCH] clock-time: make change of system's timezone change time for
5 DEFAULT_TIMEZONE
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10clock_time->timezone is set in clock_time_init so the condition
11
12'clock_time->timezone != NULL
13
14is matching always.
15
16Tested by selecting seconds displayed (-> quick update) and changing timezone.
17
18Upstream-Status: Submitted [1]
19
20[1] https://bugzilla.xfce.org/show_bug.cgi?id=12453
21
22Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
23---
24 plugins/clock/clock-time.c | 2 +-
25 1 file changed, 1 insertion(+), 1 deletion(-)
26
27diff --git a/plugins/clock/clock-time.c b/plugins/clock/clock-time.c
28index b015b13..4459b85 100644
29--- a/plugins/clock/clock-time.c
30+++ b/plugins/clock/clock-time.c
31@@ -198,7 +198,7 @@ clock_time_get_time (ClockTime *clock_time)
32
33 panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (clock_time), NULL);
34
35- if (clock_time->timezone != NULL)
36+ if (g_strcmp0 (clock_time->timezone_name, DEFAULT_TIMEZONE) != 0)
37 date_time = g_date_time_new_now (clock_time->timezone);
38 else
39 date_time = g_date_time_new_now_local ();
40--
412.5.0
42
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
index b2d960c003..1adb14552d 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
+++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
@@ -14,23 +14,23 @@ Upstream-Status: Pending
14 14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> 15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16--- 16---
17 plugins/windowmenu/windowmenu.c | 12 ++++++------ 17 plugins/windowmenu/windowmenu.c | 10 +++++-----
18 1 files changed, 6 insertions(+), 6 deletions(-) 18 1 file changed, 5 insertions(+), 5 deletions(-)
19 19
20diff --git a/plugins/windowmenu/windowmenu.c b/plugins/windowmenu/windowmenu.c 20diff --git a/plugins/windowmenu/windowmenu.c b/plugins/windowmenu/windowmenu.c
21index c96123a..9404021 100644 21index f47e993e..061d6544 100644
22--- a/plugins/windowmenu/windowmenu.c 22--- a/plugins/windowmenu/windowmenu.c
23+++ b/plugins/windowmenu/windowmenu.c 23+++ b/plugins/windowmenu/windowmenu.c
24@@ -256,7 +256,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin) 24@@ -251,7 +251,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin)
25 g_signal_connect (G_OBJECT (plugin->button), "toggled", 25 g_signal_connect (G_OBJECT (plugin->button), "toggled",
26 G_CALLBACK (window_menu_plugin_menu), plugin); 26 G_CALLBACK (window_menu_plugin_menu), plugin);
27 27
28- plugin->icon = xfce_panel_image_new_from_source ("user-desktop"); 28- plugin->icon = gtk_image_new_from_icon_name ("user-desktop", GTK_ICON_SIZE_BUTTON);
29+ plugin->icon = xfce_panel_image_new_from_source (NULL); 29+ plugin->icon = gtk_image_new_from_icon_name (NULL, GTK_ICON_SIZE_BUTTON);
30 gtk_container_add (GTK_CONTAINER (plugin->button), plugin->icon); 30 gtk_container_add (GTK_CONTAINER (plugin->button), plugin->icon);
31 gtk_widget_show (plugin->icon); 31 gtk_widget_show (plugin->icon);
32 } 32 }
33@@ -634,7 +634,7 @@ window_menu_plugin_active_window_changed (WnckScreen *screen, 33@@ -640,7 +640,7 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
34 /* skip 'fake' windows */ 34 /* skip 'fake' windows */
35 type = wnck_window_get_window_type (window); 35 type = wnck_window_get_window_type (window);
36 if (type == WNCK_WINDOW_DESKTOP || type == WNCK_WINDOW_DOCK) 36 if (type == WNCK_WINDOW_DESKTOP || type == WNCK_WINDOW_DOCK)
@@ -39,22 +39,22 @@ index c96123a..9404021 100644
39 39
40 /* get the window icon and set the tooltip */ 40 /* get the window icon and set the tooltip */
41 gtk_widget_set_tooltip_text (GTK_WIDGET (icon), 41 gtk_widget_set_tooltip_text (GTK_WIDGET (icon),
42@@ -648,11 +648,11 @@ window_menu_plugin_active_window_changed (WnckScreen *screen, 42@@ -660,12 +660,12 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
43 } 43 }
44 else 44 else
45 { 45 {
46- show_desktop_icon: 46- show_desktop_icon:
47+ show_no_icon: 47+ show_no_icon:
48 48
49- /* desktop is shown right now */ 49 /* desktop is shown right now */
50- xfce_panel_image_set_from_source (icon, "user-desktop"); 50- gtk_image_set_from_icon_name (GTK_IMAGE (icon), "user-desktop", icon_size);
51+ gtk_image_set_from_icon_name (GTK_IMAGE (icon), NULL, icon_size);
52 gtk_image_set_pixel_size (GTK_IMAGE (icon), icon_size);
51- gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("Desktop")); 53- gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("Desktop"));
52+ /* no icon is shown right now */
53+ xfce_panel_image_set_from_source (icon, NULL);
54+ gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("No Windows")); 54+ gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("No Windows"));
55 } 55 }
56 } 56 }
57 } 57 }
58-- 58--
591.7.6.5 592.14.3
60 60
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.2.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb
index 9cc9a4bbce..dea0c357e2 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.2.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb
@@ -2,21 +2,18 @@ SUMMARY = "Xfce4 Panel"
2SECTION = "x11" 2SECTION = "x11"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee" 4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
5DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck" 5DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck3 vala-native"
6 6
7inherit xfce gtk-doc distro_features_check gtk-icon-cache 7inherit xfce gtk-doc gobject-introspection distro_features_check gtk-icon-cache
8 8
9REQUIRED_DISTRO_FEATURES = "x11" 9REQUIRED_DISTRO_FEATURES = "x11"
10 10
11SRC_URI[md5sum] = "803c9aabc2925dc97f96de125c52ba2e" 11SRC_URI[md5sum] = "0ccb448e3792949eb0ae9db8dc22789b"
12SRC_URI[sha256sum] = "42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9" 12SRC_URI[sha256sum] = "b467feb7ee9797ad12f56a152570e42a96b94ad63580d45536aabee282440ce8"
13SRC_URI += " \ 13SRC_URI += " \
14 file://0001-clock-time-make-change-of-system-s-timezone-change-t.patch \ 14 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
15 file://0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
16" 15"
17 16
18EXTRA_OECONF += "--enable-gtk3"
19
20python populate_packages_prepend() { 17python populate_packages_prepend() {
21 plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/') 18 plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
22 plugin_name = d.expand('${PN}-plugin-%s') 19 plugin_name = d.expand('${PN}-plugin-%s')