summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-10-31 23:10:48 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-22 13:59:42 +0100
commit794acac89d12aceb181d17d7e3ede9b5e7bab6c8 (patch)
tree37f1ca54ec6c0d9f5c04d5b4122091d42446a4a3 /meta-xfce/recipes-xfce
parent5e4fd050be4be50fd26dd1c4c8ff83973a51e684 (diff)
downloadmeta-openembedded-794acac89d12aceb181d17d7e3ede9b5e7bab6c8.tar.gz
xfce4-panel: do not display desktop icon when no window is opened
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch60
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb1
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
new file mode 100644
index 000000000..b2d960c00
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
@@ -0,0 +1,60 @@
1From 0651f228cef01a6c3e4758a991cace1cd7721031 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 24 Sep 2012 09:57:46 +0200
4Subject: [PATCH] windowmenu: do not display desktop icon when no window is
5 active
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10* desktop icon is of no use
11* desktop icon confuses when using showdesktop plugin
12
13Upstream-Status: Pending
14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16---
17 plugins/windowmenu/windowmenu.c | 12 ++++++------
18 1 files changed, 6 insertions(+), 6 deletions(-)
19
20diff --git a/plugins/windowmenu/windowmenu.c b/plugins/windowmenu/windowmenu.c
21index c96123a..9404021 100644
22--- a/plugins/windowmenu/windowmenu.c
23+++ b/plugins/windowmenu/windowmenu.c
24@@ -256,7 +256,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin)
25 g_signal_connect (G_OBJECT (plugin->button), "toggled",
26 G_CALLBACK (window_menu_plugin_menu), plugin);
27
28- plugin->icon = xfce_panel_image_new_from_source ("user-desktop");
29+ plugin->icon = xfce_panel_image_new_from_source (NULL);
30 gtk_container_add (GTK_CONTAINER (plugin->button), plugin->icon);
31 gtk_widget_show (plugin->icon);
32 }
33@@ -634,7 +634,7 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
34 /* skip 'fake' windows */
35 type = wnck_window_get_window_type (window);
36 if (type == WNCK_WINDOW_DESKTOP || type == WNCK_WINDOW_DOCK)
37- goto show_desktop_icon;
38+ goto show_no_icon;
39
40 /* get the window icon and set the tooltip */
41 gtk_widget_set_tooltip_text (GTK_WIDGET (icon),
42@@ -648,11 +648,11 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
43 }
44 else
45 {
46- show_desktop_icon:
47+ show_no_icon:
48
49- /* desktop is shown right now */
50- xfce_panel_image_set_from_source (icon, "user-desktop");
51- gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("Desktop"));
52+ /* no icon is shown right now */
53+ xfce_panel_image_set_from_source (icon, NULL);
54+ gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("No Windows"));
55 }
56 }
57 }
58--
591.7.6.5
60
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
index 6a2b944be..4148d9af4 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
@@ -11,6 +11,7 @@ SRC_URI[sha256sum] = "30920fc2e2fc26279a82b5261a155c2cc15ab2aa1ced2275684a6ff826
11SRC_URI += " \ 11SRC_URI += " \
12 file://0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch \ 12 file://0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch \
13 file://0002-clock-time-make-change-of-system-s-timezone-change-t.patch \ 13 file://0002-clock-time-make-change-of-system-s-timezone-change-t.patch \
14 file://0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
14" 15"
15 16
16EXTRA_OECONF += "--enable-gtk3" 17EXTRA_OECONF += "--enable-gtk3"