summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-01-03 15:12:33 +0100
committerKhem Raj <raj.khem@gmail.com>2021-01-05 09:16:26 -0800
commite01e88e7543ca6b3b985b0207c4843e830aba5ae (patch)
treecaf90c8eb7252292b5a09a1deb63de675ba529c4 /meta-xfce/recipes-panel-plugins
parent70b6a60b7b7dbb01200b1c9d3887b548e3fcbae6 (diff)
downloadmeta-openembedded-e01e88e7543ca6b3b985b0207c4843e830aba5ae.tar.gz
xfce4-mount-plugin: upgrade 1.1.3 -> 1.1.5
Release notes for 1.1.5 ======================= Updated and revised German translation; further enhanced autotools setup; checked compilation and functionality on FreeBSD 12.2. Release notes for 1.1.4 ======================= - Remove unused variable exclude_devicenames - Remove obsolete panel version 4.9 check - Remove checks for unused functions from configure.ac - Include stdlib because malloc is used - Spellfix. Add missing "e" to siz (size) - Update URLs from goodies.x.o to docs.x.o (Bug #16168) - Fix build with panel 4.15 - Make build less verbose - Another change to the SVG icon file canvas size - Updated svg image to have a larger canvas so that the panel can be resized up to 192 pixels size - Added title to popup menu; even if it is not empty (Bug #14478) - https URL instead of http - Renamed improperly named member variable of main mountpoint display structure - Display percentage on progress bar again (regression from port to Gtk3) - Reformatted popup information with more columns and nicer alignment. (Bug #14670) - Fix bug 13624 by not trying to save when closing the plugin, but already and only when closing the settings dialog - Translation Updates: Albanian, Arabic, Asturian, Basque, Belarusian, Bulgarian, Catalan, Chinese (China), Chinese (Taiwan), Croatian, Czech, Danish, Dutch, Eastern Armenian, English (Australia), English (United Kingdom), Finnish, French, Galician, German, Greek, Hebrew, Hungarian, Icelandic, Indonesian, Interlingue, Italian, Japanese, Korean, Latvian, Lithuanian, Malay, Norwegian Bokmål, Occitan (post 1500), Panjabi (Punjabi), Polish, Portuguese, Portuguese (Brazil), Russian, Serbian, Slovak, Spanish, Swedish, Thai, Turkish, Ukrainian, Urdu, Urdu (Pakistan), Uyghur Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins')
-rw-r--r--meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch30
-rw-r--r--meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin_1.1.5.bb (renamed from meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin_1.1.3.bb)4
2 files changed, 17 insertions, 17 deletions
diff --git a/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch b/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
index e2165c2fa..d81f70289 100644
--- a/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
+++ b/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
@@ -14,38 +14,38 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
14Patch Reworked for xfce4-mount-plugin 0.6.4->1.1.2 14Patch Reworked for xfce4-mount-plugin 0.6.4->1.1.2
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> 15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16--- 16---
17 configure.ac | 1 + 17 configure.ac | 2 +
18 panel-plugin/devices.c | 22 +++++++++++++++++++--- 18 panel-plugin/devices.c | 22 +++++++++++++++++++---
19 2 files changed, 20 insertions(+), 3 deletions(-) 19 2 files changed, 21 insertions(+), 3 deletions(-)
20 20
21diff --git a/configure.ac b/configure.ac 21diff --git a/configure.ac b/configure.ac
22index b131117..c633fef 100644 22index 375e64a..590b7ad 100644
23--- a/configure.ac 23--- a/configure.ac
24+++ b/configure.ac 24+++ b/configure.ac
25@@ -69,6 +69,7 @@ AC_CHECK_HEADERS([sys/socket.h]) 25@@ -65,6 +65,9 @@ dnl param.h is part of libc6 on Linux, but important for old-style Unix and espe
26 AC_CHECK_HEADERS([sys/time.h]) 26 AC_CHECK_HEADERS([sys/param.h])
27 AC_CHECK_HEADERS([unistd.h]) 27 AC_CHECK_HEADERS([sys/mount.h])
28 AC_CHECK_HEADERS([sys/sockio.h]) 28
29+dnl make musl happy
29+AC_CHECK_HEADERS([fstab.h]) 30+AC_CHECK_HEADERS([fstab.h])
30 AC_HEADER_SYS_WAIT 31+
31 AC_PROG_GCC_TRADITIONAL 32 dnl Add -traditional to output variable CC if using the GNU C compiler and ioctl does not work properly without -traditional. That usually happens when the fixed header files have not been installed on an old system. Leave here commented out to comment in if some older *NIX systems might require it as was recently written on the ML.
32 AC_TYPE_SIZE_T 33 dnl AC_PROG_GCC_TRADITIONAL
34
33diff --git a/panel-plugin/devices.c b/panel-plugin/devices.c 35diff --git a/panel-plugin/devices.c b/panel-plugin/devices.c
34index 797b079..d29df56 100644 36index 797b079..d29df56 100644
35--- a/panel-plugin/devices.c 37--- a/panel-plugin/devices.c
36+++ b/panel-plugin/devices.c 38+++ b/panel-plugin/devices.c
37@@ -24,8 +24,10 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. 39@@ -25,7 +25,9 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
38 #ifdef HAVE_CONFIG_H
39 #include <config.h> 40 #include <config.h>
40 #endif 41 #endif
41- 42
42+#if HAVE_FSTAB_H 43+#if HAVE_FSTAB_H
43 #include <fstab.h> 44 #include <fstab.h>
44+#endif 45+#endif
45+
46 #include <glib.h> 46 #include <glib.h>
47 #include <stdio.h> 47 #include <stdio.h>
48 #include <string.h> 48 #include <stdlib.h>
49@@ -468,11 +470,12 @@ disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length) 49@@ -468,11 +470,12 @@ disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length)
50 { 50 {
51 GPtrArray * pdisks; /* to be returned */ 51 GPtrArray * pdisks; /* to be returned */
diff --git a/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin_1.1.3.bb b/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin_1.1.5.bb
index 4600104ad..3f35b8c24 100644
--- a/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin_1.1.3.bb
+++ b/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin_1.1.5.bb
@@ -7,5 +7,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7inherit xfce-panel-plugin 7inherit xfce-panel-plugin
8 8
9SRC_URI += "file://0001-check-for-fstab.h-during-configure.patch" 9SRC_URI += "file://0001-check-for-fstab.h-during-configure.patch"
10SRC_URI[md5sum] = "2f1f903d0bdf6ee6776afd8af73497ac" 10
11SRC_URI[sha256sum] = "aae5bd6b984bc78daf6b5fb9d15817a27253674a4264ad60f62ccb1aa194911e" 11SRC_URI[sha256sum] = "584cd954929e542b3da0ff8d69e0325d8838dc39e7b32a509d1074ce3bb58ec2"