summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins/cpugraph
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmx.de>2011-10-18 08:49:21 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-18 11:18:13 +0200
commitb618634b58f9f4191006532a811909a0af039da1 (patch)
tree80122c51ac8a38ad857054e39fc50ea35138621c /meta-xfce/recipes-panel-plugins/cpugraph
parent2062647dae2a38705cd18c1f9aa0c548565d7968 (diff)
downloadmeta-openembedded-b618634b58f9f4191006532a811909a0af039da1.tar.gz
xfce4-cpugraph-plugin: initial add 1.0.1
* based on Koen's patch [1] * xfce4-cpugraph-plugin ported to libxfce4ui [1] http://lists.linuxtogo.org/pipermail/openembedded-devel/2011-October/035591.html Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/cpugraph')
-rw-r--r--meta-xfce/recipes-panel-plugins/cpugraph/files/port-to-libxfce4ui.patch102
-rw-r--r--meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.1.bb11
2 files changed, 113 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/cpugraph/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/cpugraph/files/port-to-libxfce4ui.patch
new file mode 100644
index 000000000..cb8025a57
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/cpugraph/files/port-to-libxfce4ui.patch
@@ -0,0 +1,102 @@
1From 2db9e1d1a91ea335bfede19ec513dee69569f60a Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmx.de>
3Date: Tue, 18 Oct 2011 01:43:30 +0200
4Subject: [PATCH] port to libxfce4ui
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9
10Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
11---
12 configure.ac | 4 ++--
13 panel-plugin/Makefile.am | 4 ++--
14 panel-plugin/cpu.c | 4 ++--
15 panel-plugin/properties.c | 2 +-
16 panel-plugin/settings.c | 2 +-
17 5 files changed, 8 insertions(+), 8 deletions(-)
18
19diff --git a/configure.ac b/configure.ac
20index e20015e..3aa57bb 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -27,8 +27,8 @@ dnl Check for standard header files
24 AC_HEADER_STDC
25
26 dnl configure the panel plugin
27-XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.20])
28-XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.20])
29+XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.8.0])
30+XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.8.0])
31 XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.12.0])
32
33 dnl translations
34diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am
35index 595c61f..6340196 100644
36--- a/panel-plugin/Makefile.am
37+++ b/panel-plugin/Makefile.am
38@@ -3,11 +3,11 @@ plugin_PROGRAMS = xfce4-cpugraph-plugin
39
40 xfce4_cpugraph_plugin_CFLAGS = \
41 -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
42- @LIBXFCEGUI4_CFLAGS@ \
43+ @LIBXFCE4UI_CFLAGS@ \
44 @LIBXFCE4PANEL_CFLAGS@
45
46 xfce4_cpugraph_plugin_LDADD = \
47- @LIBXFCEGUI4_LIBS@ \
48+ @LIBXFCE4UI_LIBS@ \
49 @LIBXFCE4PANEL_LIBS@
50
51 xfce4_cpugraph_plugin_SOURCES = \
52diff --git a/panel-plugin/cpu.c b/panel-plugin/cpu.c
53index 63431f6..1f13b51 100644
54--- a/panel-plugin/cpu.c
55+++ b/panel-plugin/cpu.c
56@@ -26,7 +26,7 @@
57 #include "mode.h"
58 #include "properties.h"
59
60-#include <libxfcegui4/libxfcegui4.h>
61+#include <libxfce4ui/libxfce4ui.h>
62 #include <libxfce4panel/xfce-hvbox.h>
63 #ifndef _
64 # include <libintl.h>
65@@ -344,7 +344,7 @@ static gboolean command_cb( GtkWidget *w,GdkEventButton *event, CPUGraph *base )
66 {
67 if( event->button == 1 && base->command )
68 {
69- xfce_exec( base->command, base->in_terminal, base->startup_notification, NULL );
70+ xfce_spawn_command_line_on_screen( gdk_screen_get_default(), base->command, base->in_terminal, base->startup_notification, NULL );
71 }
72 return FALSE;
73 }
74diff --git a/panel-plugin/properties.c b/panel-plugin/properties.c
75index 411fafd..ed191dd 100644
76--- a/panel-plugin/properties.c
77+++ b/panel-plugin/properties.c
78@@ -26,7 +26,7 @@
79 #include "settings.h"
80
81 #include <glib/gprintf.h>
82-#include <libxfcegui4/libxfcegui4.h>
83+#include <libxfce4ui/libxfce4ui.h>
84
85 #ifndef _
86 # include <libintl.h>
87diff --git a/panel-plugin/settings.c b/panel-plugin/settings.c
88index dcc474e..c0f1fed 100644
89--- a/panel-plugin/settings.c
90+++ b/panel-plugin/settings.c
91@@ -22,7 +22,7 @@
92 * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
93 */
94 #include "settings.h"
95-#include <libxfcegui4/libxfcegui4.h>
96+#include <libxfce4ui/libxfce4ui.h>
97
98 static void default_command( const gchar ** command, gboolean * in_terminal, gboolean * startup_notification )
99 {
100--
1011.7.4.4
102
diff --git a/meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.1.bb b/meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.1.bb
new file mode 100644
index 000000000..abbc7f1cc
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.1.bb
@@ -0,0 +1,11 @@
1DESCRIPTION = "Panel plugin with graphical representation of the cpu frequency"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=415654f59d8fa70fe4eac2c3f86c8f5e"
5
6inherit xfce-panel-plugin
7
8# SRC_URI must follow inherited one
9SRC_URI += "file://port-to-libxfce4ui.patch"
10SRC_URI[md5sum] = "ff551087b1f61c47b8746e8687c572aa"
11SRC_URI[sha256sum] = "b5fada35a92083b67818da0ce3fe5ba6a2443fee26d6eec71755ff383df7c407"