summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-art
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-xfce/recipes-art
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-xfce/recipes-art')
-rw-r--r--meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb29
-rw-r--r--meta-xfce/recipes-art/xfce4-icon-theme/xfce4-icon-theme_4.4.3.bb14
-rw-r--r--meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb19
3 files changed, 62 insertions, 0 deletions
diff --git a/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb b/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
new file mode 100644
index 000000000..9547736bd
--- /dev/null
+++ b/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
@@ -0,0 +1,29 @@
1SUMMARY = "X11 Mouse Theme"
2HOMEPAGE = "http://xfce-look.org/content/show.php/OpenZone?content=111343"
3SECTION = "x11/wm"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a2f562fb8fb1e138b810d69521c4bcd7"
6DEPENDS = "icon-slicer-native xcursorgen-native"
7
8inherit allarch
9
10SRC_URI = "http://xfce-look.org/CONTENT/content-files/111343-OpenZone-${PV}.tar.xz"
11SRC_URI[md5sum] = "4dae968cbd525072664ef7a4fc7c4154"
12SRC_URI[sha256sum] = "dc20f97a49e1ff1becf7853ef5f137ed30a4c27490540e755021d78d339efd92"
13
14S = "${WORKDIR}/OpenZone"
15
16do_install() {
17 install -d ${D}${datadir}/icons
18 for theme in `find -name '*.tar.xz'`; do
19 tar -Jxf ${theme} -C ${D}${datadir}/icons
20 done
21}
22
23python populate_packages_prepend () {
24 icondir = bb.data.expand('${datadir}/icons', d)
25 do_split_packages(d, icondir, '^(.*)', '%s', 'Open Zone cursors %s', allow_dirs=True)
26}
27
28PACKAGES_DYNAMIC += "^openzone-.*"
29ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-xfce/recipes-art/xfce4-icon-theme/xfce4-icon-theme_4.4.3.bb b/meta-xfce/recipes-art/xfce4-icon-theme/xfce4-icon-theme_4.4.3.bb
new file mode 100644
index 000000000..1e4b06bfe
--- /dev/null
+++ b/meta-xfce/recipes-art/xfce4-icon-theme/xfce4-icon-theme_4.4.3.bb
@@ -0,0 +1,14 @@
1SUMMARY = "xfce4 icon theme rodent"
2SECTION = "x11/wm"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6DEPENDS = "intltool-native xfce4-dev-tools-native"
7
8inherit xfce
9
10SRC_URI = "http://archive.xfce.org/src/art/${BPN}/${@'${PV}'[0:3]}/${BP}.tar.bz2"
11SRC_URI[md5sum] = "73ce2977b84f634a6a6c5d9c27e336db"
12SRC_URI[sha256sum] = "d4786692d56b8a563f66a5f260f1f13ade11e86c78cbcb25a9f9a5fc47cf66fa"
13
14FILES_${PN} += "${datadir}/xfce4/mime"
diff --git a/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb b/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb
new file mode 100644
index 000000000..7030f7a26
--- /dev/null
+++ b/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Additional (old) themes for Xfwm4"
2SECTION = "x11/wm"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6inherit xfce
7
8SRC_URI = "http://archive.xfce.org/src/art/${BPN}/${@'${PV}'[0:4]}/${BP}.tar.bz2"
9SRC_URI[md5sum] = "eaa58362053a3549c8be0b32efd3c54f"
10SRC_URI[sha256sum] = "3214d5f00e9703b5e8c9e7c3287d606dedec7285ceb4d5db332e93ada66fd575"
11
12# using xfwm4-theme as in xfwm4 might cause warnings of packages supplied by
13# multiple providers. So we use xfwm4-old-theme here.
14python populate_packages_prepend () {
15 themedir = d.expand('${datadir}/themes')
16 do_split_packages(d, themedir, '^(.*)', 'xfwm4-old-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
17}
18
19PACKAGES_DYNAMIC += "^xfwm4-old-theme-.*"