summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-apps
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-10-31 23:10:40 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-22 13:59:37 +0100
commitfa933acd44a84d0b5022f23d768b05a2b5a2202d (patch)
treed4ed689b7bde870045b2fc818cc8fb4f57369059 /meta-xfce/recipes-apps
parent6914eb6354189dd3b625192e12b22e64f277e236 (diff)
downloadmeta-openembedded-fa933acd44a84d0b5022f23d768b05a2b5a2202d.tar.gz
menulibre: initial add 2.1.3
it was added in meta-xfce for two reasons: * xfce4-whiskermenu-plugin suggests menulibre as menu editor * meta-xfce requires meta-python already and menulibre requires some recipes within meta-python Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-apps')
-rw-r--r--meta-xfce/recipes-apps/menulibre/files/0001-add_launcher-Exit-early-if-no-row-is-selected.patch37
-rw-r--r--meta-xfce/recipes-apps/menulibre/files/0002-setup.py-avoid-usr-share-share-paths.patch40
-rw-r--r--meta-xfce/recipes-apps/menulibre/files/0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch36
-rw-r--r--meta-xfce/recipes-apps/menulibre/menulibre_2.1.3.bb36
4 files changed, 149 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/menulibre/files/0001-add_launcher-Exit-early-if-no-row-is-selected.patch b/meta-xfce/recipes-apps/menulibre/files/0001-add_launcher-Exit-early-if-no-row-is-selected.patch
new file mode 100644
index 000000000..fb2dfc90a
--- /dev/null
+++ b/meta-xfce/recipes-apps/menulibre/files/0001-add_launcher-Exit-early-if-no-row-is-selected.patch
@@ -0,0 +1,37 @@
1From 1060e7ac8a63b93d56006718f0e9b1d9382b2226 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 31 Oct 2016 08:33:16 +0100
4Subject: [PATCH] add_launcher: Exit early if no row is selected
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Stolen from [1]
10
11[1] http://pkgs.fedoraproject.org/cgit/rpms/menulibre.git/tree/menulibre-add-launcher-none-check.patch
12
13Upstream-Status: Pending
14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16---
17 menulibre/MenulibreApplication.py | 4 ++++
18 1 file changed, 4 insertions(+)
19
20diff --git a/menulibre/MenulibreApplication.py b/menulibre/MenulibreApplication.py
21index e234800..ac73b03 100644
22--- a/menulibre/MenulibreApplication.py
23+++ b/menulibre/MenulibreApplication.py
24@@ -1418,6 +1418,10 @@ class MenulibreWindow(Gtk.ApplicationWindow):
25 model, parent_data = self.treeview.get_parent_row_data()
26 model, row_data = self.treeview.get_selected_row_data()
27
28+ # Exit early if no row is selected
29+ if not row_data:
30+ return
31+
32 # Currently selected item is a directory, take its categories.
33 if row_data[2] == MenuItemTypes.DIRECTORY:
34 self.treeview.add_child(new_row_data)
35--
362.5.5
37
diff --git a/meta-xfce/recipes-apps/menulibre/files/0002-setup.py-avoid-usr-share-share-paths.patch b/meta-xfce/recipes-apps/menulibre/files/0002-setup.py-avoid-usr-share-share-paths.patch
new file mode 100644
index 000000000..b63d4dc3b
--- /dev/null
+++ b/meta-xfce/recipes-apps/menulibre/files/0002-setup.py-avoid-usr-share-share-paths.patch
@@ -0,0 +1,40 @@
1From 99788b4557543c490493ce1b827538c49142c25d Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 31 Oct 2016 09:08:51 +0100
4Subject: [PATCH] setup.py: avoid /usr/share/share paths
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 setup.py | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/setup.py b/setup.py
17index 5fc237d..c4fbf7c 100644
18--- a/setup.py
19+++ b/setup.py
20@@ -143,7 +143,7 @@ class InstallAndUpdateDataDirectory(DistUtilsExtra.auto.install_auto):
21
22 if self.root:
23 target_data = os.path.relpath(self.install_data, self.root) + os.sep
24- target_pkgdata = os.path.join(target_data, 'share', 'menulibre', '')
25+ target_pkgdata = os.path.join(target_data, 'menulibre', '')
26 target_scripts = os.path.join(self.install_scripts, '')
27
28 data_dir = os.path.join(self.prefix, 'share', 'menulibre', '')
29@@ -152,7 +152,7 @@ class InstallAndUpdateDataDirectory(DistUtilsExtra.auto.install_auto):
30 # --user install
31 self.root = ''
32 target_data = os.path.relpath(self.install_data) + os.sep
33- target_pkgdata = os.path.join(target_data, 'share', 'menulibre', '')
34+ target_pkgdata = os.path.join(target_data, 'menulibre', '')
35 target_scripts = os.path.join(self.install_scripts, '')
36
37 # Use absolute paths
38--
392.5.5
40
diff --git a/meta-xfce/recipes-apps/menulibre/files/0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch b/meta-xfce/recipes-apps/menulibre/files/0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch
new file mode 100644
index 000000000..1e92088e1
--- /dev/null
+++ b/meta-xfce/recipes-apps/menulibre/files/0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch
@@ -0,0 +1,36 @@
1From 90098d835b62b38ac396d55b80a684770dbaacde Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 31 Oct 2016 15:50:52 +0100
4Subject: [PATCH] MenulibreXdg.py: fix loading of desktop files
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9fixes:
10| UnicodeDecodeError: 'ascii' codec can't decode byet 0xd9 in position 235: ordinal not in range(128)
11
12and information display not properly filled.
13
14Upstream-Status: Pending
15
16Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
17---
18 menulibre/MenulibreXdg.py | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/menulibre/MenulibreXdg.py b/menulibre/MenulibreXdg.py
22index e04c5e6..14b2593 100644
23--- a/menulibre/MenulibreXdg.py
24+++ b/menulibre/MenulibreXdg.py
25@@ -74,7 +74,7 @@ class MenulibreDesktopEntry:
26
27 def load_properties(self, filename):
28 """Load the properties."""
29- input_file = open(filename)
30+ input_file = open(filename, 'rt', encoding='utf-8')
31 self.load_properties_from_text(input_file.read())
32 input_file.close()
33
34--
352.5.5
36
diff --git a/meta-xfce/recipes-apps/menulibre/menulibre_2.1.3.bb b/meta-xfce/recipes-apps/menulibre/menulibre_2.1.3.bb
new file mode 100644
index 000000000..e945f013a
--- /dev/null
+++ b/meta-xfce/recipes-apps/menulibre/menulibre_2.1.3.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "An advanced menu editor"
2HOMEPAGE = "https://launchpad.net/menulibre"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = "python3-distutils-extra-native"
8
9inherit distutils3 gtk-icon-cache
10
11SRC_URI = " \
12 https://launchpad.net/menulibre/2.1/${PV}/+download/${PN}-${PV}.tar.gz \
13 file://0001-add_launcher-Exit-early-if-no-row-is-selected.patch \
14 file://0002-setup.py-avoid-usr-share-share-paths.patch \
15 file://0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch \
16"
17SRC_URI[md5sum] = "19d9d3337322eb5513454bb8cdfb739b"
18SRC_URI[sha256sum] = "bdd69740119902f1b1f8c7831155f4428403792a0a6c4287bcbb395c4e71fb31"
19
20do_install_append() {
21 sed -i 's:${D}::g' ${D}${datadir}/applications/menulibre.desktop
22}
23
24FILES_${PN} += " \
25 ${datadir}/applications \
26 ${datadir}/menulibre \
27 ${datadir}/icons \
28"
29
30RDEPENDS_${PN} += " \
31 gtk+3 \
32 python3-pygobject \
33 gnome-menus3 \
34 python3-unixadmin \
35 python3-psutil \
36"