summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-webadmin
diff options
context:
space:
mode:
authorJan Vermaete <jan.vermaete@gmail.com>2022-01-30 19:09:34 +0100
committerKhem Raj <raj.khem@gmail.com>2022-02-03 08:41:05 -0800
commit32dd133a6bb193985f5214ee35ab9903305e8742 (patch)
tree6e6fe48c459dd52325886130ccfd3005e69c95b3 /meta-webserver/recipes-webadmin
parentd0454ed6e60f3c52f2cfe521d78012ccd155336a (diff)
downloadmeta-openembedded-32dd133a6bb193985f5214ee35ab9903305e8742.tar.gz
netdata: upgrade 1.32.1 -> 1.33.0
Added the packageconfig to compress the data with lz4. But disabled it by default. Patch added to have it working without compression enabled. Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-webadmin')
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch26
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb (renamed from meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb)12
2 files changed, 35 insertions, 3 deletions
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch b/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch
new file mode 100644
index 000000000..c699f956d
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch
@@ -0,0 +1,26 @@
1From 85e59be1c656b946a1fcd19404cb0df6095e7dfb Mon Sep 17 00:00:00 2001
2From: odynik <odynik.ee@gmail.com>
3Date: Fri, 28 Jan 2022 12:15:41 +0200
4Subject: [PATCH 1/4] [Stream Compression] - Bug fix #12043 - lz4.h compilation
5 error - compile from source (#12049)
6
7---
8 streaming/compression.c | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/streaming/compression.c b/streaming/compression.c
12index 917f05bd6..93810aaed 100644
13--- a/streaming/compression.c
14+++ b/streaming/compression.c
15@@ -1,7 +1,7 @@
16 #include "rrdpush.h"
17-#include "lz4.h"
18
19 #ifdef ENABLE_COMPRESSION
20+#include "lz4.h"
21
22 #define LZ4_MAX_MSG_SIZE 0x4000
23 #define LZ4_STREAM_BUFFER_SIZE (0x10000 + LZ4_MAX_MSG_SIZE)
24--
252.25.1
26
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb
index dbce1c432..8b6432cec 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb
@@ -5,10 +5,13 @@ DESCRIPTION = "Netdata is high-fidelity infrastructure monitoring and troublesho
5LICENSE = "GPLv3" 5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
7 7
8DEPENDS += "libuv openssl util-linux zlib " 8DEPENDS += "libuv openssl util-linux zlib"
9 9
10SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-v${PV}.tar.gz" 10SRC_URI = "\
11SRC_URI[sha256sum] = "ac406513e86ad24976a66146702aeac960e43908abc51d70e4a073905275d13e" 11 https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz \
12 file://0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch \
13"
14SRC_URI[sha256sum] = "d167d4b2d8529119fa4047ae40d22833dac9d360a6ed07c314ba313807c027eb"
12 15
13# default netdata.conf for netdata configuration 16# default netdata.conf for netdata configuration
14SRC_URI += "file://netdata.conf" 17SRC_URI += "file://netdata.conf"
@@ -40,6 +43,9 @@ SYSTEMD_AUTO_ENABLE:${PN} = "enable"
40USERADD_PACKAGES = "${PN}" 43USERADD_PACKAGES = "${PN}"
41USERADD_PARAM:${PN} = "--system --no-create-home --home-dir ${localstatedir}/run/netdata --user-group netdata" 44USERADD_PARAM:${PN} = "--system --no-create-home --home-dir ${localstatedir}/run/netdata --user-group netdata"
42 45
46PACKAGECONFIG ??= ""
47PACKAGECONFIG[compression] = "--enable-compression, --disable-compression, lz4"
48
43# ebpf doesn't compile (or detect) the cross compilation well 49# ebpf doesn't compile (or detect) the cross compilation well
44EXTRA_OECONF += "--disable-ebpf" 50EXTRA_OECONF += "--disable-ebpf"
45 51