summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2013-10-07 09:39:08 -0700
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-10-14 14:31:41 +0100
commit29390a3a8189277efb7e077a97f33fb1a2d5b953 (patch)
treec81841dc3705f606b58b48613f5ead8ba8c6cff4 /meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb
parent9fede488dc6f1320f6000be93953a887ade52eb7 (diff)
downloadmeta-openembedded-29390a3a8189277efb7e077a97f33fb1a2d5b953.tar.gz
xdebug: update to version 2.2.3
Version 2.2.1 will not build with modphp 5.5. Signed-off-by: Joe Slater <jslater@windriver.com>
Diffstat (limited to 'meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb')
-rw-r--r--meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb
new file mode 100644
index 000000000..3e9c982a2
--- /dev/null
+++ b/meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Debugging and profiling extension for PHP"
2LICENSE = "Xdebug"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=34df3a274aa12b795417c65634c07f16"
4
5DEPENDS = "modphp"
6
7PR = "r0"
8
9SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
10
11SRC_URI[md5sum] = "e49cec9861b45dc0b36eae33bf8a14fa"
12SRC_URI[sha256sum] = "b351872da46ed8378dff90a87673f5ec1e0bdd94324558ebc898e1d115e9d71c"
13
14inherit autotools
15
16EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
17
18do_configure() {
19 ${STAGING_BINDIR_CROSS}/phpize
20
21 # Running autoreconf as autotools_do_configure would do here
22 # breaks the libtool configuration resulting in a failure later
23 # in do_compile. It's possible this may be fixable, however the
24 # easiest course of action for the moment is to avoid doing that.
25 oe_runconf
26}
27
28do_install() {
29 oe_runmake install INSTALL_ROOT=${D}
30}
31
32FILES_${PN} += "${libdir}/php5/extensions/*/*.so"
33FILES_${PN}-dbg += "${libdir}/php5/extensions/*/.debug"
34